Firefox access denied after enabling first-party isolation


#1

Hello,
Since i activate first party isolate on FF, i have a weird message here: :frowning:
Access Denied
while trying to load /new.json?order=default
Something went wrong.

Any idea?

Thanks


[Stable Update] 2018-01-05 - Kernels, KPTI, Plasma, Calamares, TLP
#2

Please clear your browser cache and try again. You’ve probably logged yourself out.


#3

Hello,
Same problem here (browser cache cleared): it happens when i click on “New”; i can access to the forum without problems.


#4

I can’t replicate it with my Firefox instance.

Could you try with Firefox in Safe Mode and then with a clean profile?


#5

Same for me in safe mode and with a new profile.
If i change to true firstpartyisolate in FF, i have this message: Access Denied
while trying to load /new.json?order=default


#6

I still can’t replicate this with a fresh Firefox (57.0.4) profile and setting privacy.firstparty.isolate=true.

After logging in to the forum I can navigate to https://forum.manjaro.org/new and https://forum.manjaro.org/new.json?order=default without issue.

The only warnings in the forum logs for that URL are from someone using Chrome, and they’re not “Access Denied” errors.


#7

Weird…
I tried with chromium and there is no problem at al (https://support.google.com/chrome/answer/7623121?hl=en-GB)l…

Also, on FF(57.0.3), when i acitvate first party isolate, i have to reconnect to all sites and forums with my login.


#8

That’s expected - each top-level domain gets its own set of cookies, so the current shared set is invalidated.


#9

Yes but it doesn’t happen with chromium… :thinking:
FF57.0.4: no change…


#10

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.