Finally managed to get sound, but mic still not working


Recently switched from Ubuntu to Manjaro, because Ubuntu was causing weird issues on my laptop and I couldn’t find any help with the issues, despite many attempts.

It use to work when I first installed Ubuntu, but some update messed up and sound stopped working, and with a later update my touchscreen had a weird graphics lag which meant it was unusable.

A fresh Manjaro install fixed the weird graphics issue (yay), and with a command found here (in this forum) finally got the output sound to work again. Seems I have an old Intel card that requires a legacy driver.

sudo tee /etc/modprobe.d/audio.conf <<< 'options snd-intel-dspcfg dsp_driver=1

That’s a huge improvement from no sound at all. But can anyone here help me get the internal mic working againg as well? It seems that it is recognised somewhere, but it doesn’t work.

System info (note: before running the above command, there was just dummy output and alsa didn’t detect any sound card, much the same as in the thread linked above)

$ inxi -SMxxA
  Host: audun-hpspectrefolioconvertible13ak0xxx Kernel: 6.1.38-1-MANJARO
    arch: x86_64 bits: 64 compiler: gcc v: 13.1.1 Desktop: GNOME v: 44.3 tk: GTK
    v: 3.24.38 wm: gnome-shell dm: GDM Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: HP product: HP Spectre Folio Convertible 13-ak0xxx
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 31
    serial: <superuser required>
  Mobo: HP model: 8503 v: 14.54 serial: <superuser required> UEFI: Insyde
    v: F.58 date: 04/17/2023
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71
  API: ALSA v: k6.1.38-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.74 status: off
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin

$ cat /proc/asound/cards                             
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0x2ffb018000 irq 164

$ pacmd list-sinks   

1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	state: IDLE
	suspend cause: (none)
	priority: 9039
	volume: front-left: 30129 /  46% / -20.25 dB,   front-right: 30129 /  46% / -20.25 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: yes
	current latency: 33.86 ms
	max request: 7 KiB
	max rewind: 7 KiB
	monitor source: 0
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	used by: 0
	linked by: 1
	configured latency: 40.00 ms; range is 0.50 .. 2000.00 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 6
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix" = "ALC285 Analog" = "ALC285 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0x2ffb018000 irq 164"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci" = "8086" = "Intel Corporation" = "9d71" = "Sunrise Point-LP HD Audio"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "384000"
		device.buffering.fragment_size = "192000"
		device.access_mode = "mmap+timer" = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
				device.icon_name = "audio-headphones"
	active port: <analog-output-speaker>

I’d appreciate any help on this.

Is the correct profile selected? Usually it would be Analog Stereo Duplex.

If not available, you would need to patch the pins, since vendors often do its own modifications here. Install alsa-tools and patch it with hdajackretask. For live patching (without reboot) by clicking on apply, pulseaudio must be stopped:

systemctl --user stop pulseaudio.service

And turn it on again after patching is done:

systemctl --user start pulseaudio.service
1 Like

Thanks. I tried with hdajackretask, but couldn’t get any of the pins that was suggested as internal mic to work. As for the profile, how do I change it?

pavucontrol has that profile in the settings, so changed to duplex there, but not sure if it had any effect.

Is a microphone there? Usually, a duplex profile enables both input and output. Analog enables only output.

pactl --format=json list cards | jq '.[] | {name, active_profile}'
1 Like

I got an error with the _jq commmand (:_arguments:comparguments:327: can only be called from completion function), but looking at the list of cards it seems to be there.

I followed the instructions here and managed to get the microphone detected in pulseaudio by loading it in the configuration file. Now it shows.

Though, it still doesn’t work as it doesn’t detect any sound (neither in Gnome sound settings, alsamixer or pavucontrol).

Because it is jq and not _jq :wink:

I had to install jq it seems (zsh corrected it to _jq which confused me). Now it outputs:

  "name": "alsa_card.pci-0000_00_1f.3",
  "active_profile": "output:analog-stereo+input:analog-stereo"