Filetype = vfat ?

Kernal; 4.19.16-1
XFCE 4.134

Before I did the recent upgrade, I had no problems mounting this device. I could right click on it and it would be mounted if it had not been mounted at boot up. I still dont know why it isnt mounted at bootup but that is another problem.
Anyhow, when I try to do a rt click and mount in Thunar file manager, I get this error message.
Failed to Mount "Store and Go"
Error mounting /dev/sdi1 at /run/media/hexdump/STORE AND GO:
unknown filesystem type 'vfat'

Additionally when I try to run fstab I get:

[hexdump@corky-pc ~]$ fstab
bash: fstab: command not found

thanks

$ cat /etc/fstab


You can also try to mount the USB Stick via console.

This is usually because you have updated your kernel and have not rebooted yet.
Please reboot and try again.

1 Like

I am sorry but I dont know how to do a mount via the console.

I tried a reboot and it did no good.

[hexdump@corky-pc ~]$ cat /etc/fstab

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=78d1361b-010d-4400-8089-29c8ca07975b / ext4 defaults,noatime,discard 0 1
UUID=376fa7d9-2426-4c29-87d2-28def5bb215e swap swap defaults,noatime,discard 0 2
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0
[hexdump@corky-pc ~]$

I think that maybe I will need to figure out how to make the entry in fstab.

You could try this entry in /etc/fstab:

UUID=YOUR-UUID /run/media/hexdump/STORE_AND_GO vfat nofail,noatime,rw,user,uid=1000,gid=1000,dmask=022,fmask=133  0       0

You can find your drives UUID with this command:

lsblk -f

Replace "YOUR-UUID" with the UUID displayed for your drive in the output of lsblk -f.

The above line assumes your UID &GID are both 1000 (which is the normal values).

2 Likes

I tried to get the fstab right but I think I messed it up and I get an error when I try and mount it.
Error mounting system-managed device /dev/sdi1; cant find in /etc/fstab
Here is what fstab looks like now.

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=B4A0-8F2C /run/media/hexdump/"STORE AND GO" vfat nofail,noatime,rw,user,uid=1000,gid=1000,dmask=022,fmask=133 0
UUID=78d1361b-010d-4400-8089-29c8ca07975b / ext4 defaults,noatime,discard 0 1
UUID=376fa7d9-2426-4c29-87d2-28def5bb215e swap swap defaults,noatime,discard 0 2
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

And here are what blkid and lsblkid -f show.

/dev/sdb1: LABEL="MyData" UUID="52907dc9-b502-4a80-a293-6ce9e68b949c" TYPE="ext4" PARTUUID="e1b95b09-bf29-4464-b828-d0ba1a9ba80e"
/dev/sda1: UUID="78d1361b-010d-4400-8089-29c8ca07975b" TYPE="ext4" PARTUUID="f16fa44c-01"
/dev/sda2: UUID="376fa7d9-2426-4c29-87d2-28def5bb215e" TYPE="swap" PARTUUID="f16fa44c-02"
/dev/sdi1: LABEL_FATBOOT="STORE N GO" LABEL="STORE N GO" UUID="B4A0-8F2C" TYPE="vfat" PARTUUID="b44c0470-01"
/dev/sdh1: UUID="6042e901-7b89-4603-9c21-5a6454ece145" TYPE="ext4" PARTUUID="00088452-01"

[hexdump@corky-pc ~]$ lsblk -f
NAME FSTYPE LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
sda
├─sda1 ext4 78d1361b-010d-4400-8089-29c8ca07975b 184.9G 13% /
└─sda2 swap 376fa7d9-2426-4c29-87d2-28def5bb215e [SWAP]
sdb
└─sdb1 ext4 MyData 52907dc9-b502-4a80-a293-6ce9e68b949c 827.5G 5% /run/media/hexdump/MyData
sdh
└─sdh1 ext4 6042e901-7b89-4603-9c21-5a6454ece145 141.7G 35% /run/media/hexdump/6042e901-7b89-4603-9c21-5a
sdi
└─sdi1 vfat STORE N GO B4A0-8F2C
sr0

There are two issues that I notice with your entry.

  1. remove the double quotes and white spaces from the drive name. It is best practice in Linux not to use white spaces in a name for a drive mount (it only complicates things).

  2. you removed one of the zeros at the end of the load line. There should be 2 zeros as in "0 0" (without quotation marks).

Hopefully this line will work:

UUID=B4A0-8F2C /run/media/hexdump/STORE_AND_GO vfat nofail,noatime,rw,user,uid=1000,gid=1000,dmask=022,fmask=133 0 0

To set the ownership permissions, use the "uid" and "gid" options as in the above fstab load line.

You can find your UID with the command "id -u". To find your GID, use "id -g". These values are both normally 1000.

If the number output from either "id -u" or "id -g" is different than "1000" substitute the number returned in the relevant field of the fstab load line.

2 Likes

Is it a space that define the start and stop of the entry ?

man fstab

https://wiki.archlinux.org/index.php/Fstab

1 Like

Thank you tbg, adding the extra 0 fixed it.

Now will it stay mounted on a reboot?

1 Like

Well I spoke too soon. Let me see if I can explain the problem now. It will get mounted but I cant access it.
I think it has something to do with the label. The label is STORE N GO and my entry in fstab looks like this:
UUID=B4A0-8F2C /run/media/hexdump/

STORE\040N\040GO

vfat nofail,noatime,rw,user,uid=1000,gid=1000,dmask=022,fmask=133 0 0
believe that is what the Archwiki page was telling me to do because of the spaces.
Yet when I look in /run/media/hexdump and see what kind of entry it created, it looks like this:
STORE \N GO

Those are the complications I was speaking of with a drive with white spaces in the name.

If you want the least amount of problems in Linux I would modify the drives name/label using gparted. I would rename the drive to something with no white spaces personally.

You could change it to something much more simple such as "Storage".

While you can make white spaces work, it can create many issues. It's just much better to have no white spaces in a drive name.

BTW, did you doublecheck that your GID & UID both were 1000.

1 Like

Yes the GID and HID are both 1000, and I will change the label of the drive.
Can gparted do that without disturbing the data ?

Renaming a drive should not affect the data, as long as you do not make any other changes to the drive. You should unmount the drive first, before making changes.

You will then have match your fstab entry to whatever you named the drive to.

1 Like

Well, I think that there might be a basic problem with manjaro. Reading other forums in trying to track this down I tried this

[hexdump@corky-pc hexdump]$ sudo modprobe vfat
modprobe: FATAL: Module vfat not found in directory /lib/modules/4.19.16-1-MANJARO

That sounds like a manjaro problem.
I couldnt use gparted to change the label as I could not mount the drive.
I changed vfat and removed all the spaces and caps but still no love.
Gparted shows the correct label.
I changed them using some other terminal command that I cant find now.
How can I revert to an older kernal or get what is missing ?

https://wiki.manjaro.org/index.php/Manjaro_Kernels

Forum kindly sponsored by Bytemark