File-roller is freezing up

file-roller is freezing up on me after trying to Archive file’s.

On the other Hand, workaround with engrampa is working fine

system info
❯ inxi-Fnzy
System:
  Kernel: 6.6.34-1-MANJARO arch: x86_64 bits: 64
  Desktop: Xfce v: 4.18.1 Distro: Manjaro Linux
Machine:
  Type: Laptop System: Acer product: Nitro ANV15-51 v: V1.08
    serial: <superuser required>
  Mobo: RPL model: Sportage_RTH v: V1.08 serial: <superuser required>
    UEFI: INSYDE v: 1.08 date: 10/31/2023
Battery:
  ID-1: BAT1 charge: 58.5 Wh (100.0%) condition: 58.5/58.8 Wh (99.5%)
CPU:
  Info: 10-core (6-mt/4-st) model: 13th Gen Intel Core i7-13620H bits: 64
    type: MST AMCP cache: L2: 9.5 MiB
  Speed (MHz): avg: 568 min/max: 400/4700:4900:3600 cores: 1: 400 2: 400
    3: 400 4: 400 5: 696 6: 1159 7: 400 8: 483 9: 920 10: 400 11: 967 12: 400
    13: 400 14: 400 15: 400 16: 872
Graphics:
  Device-1: Intel Raptor Lake-P [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA AD107M [GeForce RTX 4050 Max-Q / Mobile] driver: nvidia
    v: 550.90.07
  Device-3: Quanta ACER HD User Facing driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915 resolution: 1: 1920x1080~60Hz
    2: 1920x1080~60Hz 3: 1920x1080~144Hz
  API: EGL v: 1.5 drivers: iris,kms_swrast,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
    renderer: NVIDIA GeForce RTX 4050 Laptop GPU/PCIe/SSE2
  API: Vulkan v: 1.3.279 drivers: intel,nvidia surfaces: xcb,xlib
Audio:
  Device-1: Intel Raptor Lake-P/U/H cAVS driver: sof-audio-pci-intel-tgl
  Device-2: NVIDIA driver: snd_hda_intel
  Device-3: HP USB Audio driver: hid-generic,snd-usb-audio,usbhid type: USB
  API: ALSA v: k6.6.34-1-MANJARO status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active
Network:
  Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8168
  IF: enp62s0 state: down mac: <filter>
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
  IF: enp0s13f0u1u4 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb type: USB
  Report: btmgmt ID: hci0 state: up address: <filter> bt-v: 5.2
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
    driver: vmd
Drives:
  Local Storage: total: 2.75 TiB used: 592.88 GiB (21.0%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD PC SN740
    SDDQNQD-1T00-1014 size: 953.87 GiB
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 2TB
    size: 1.82 TiB
Partition:
  ID-1: / size: 850.88 GiB used: 431.93 GiB (50.8%) fs: ext4 dev: /dev/dm-0
  ID-2: /boot/efi size: 299.4 MiB used: 448 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p6
Swap:
  ID-1: swap-1 type: file size: 21.7 GiB used: 47 MiB (0.2%) file: /swapfile
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 32 GiB note: est. available: 31.06 GiB used: 8.66 GiB (27.9%)
  Processes: 486 Uptime: 6h 11m Shell: Zsh inxi: 3.3.35