File copy on a usb 2 slows down to a halt

Hi I wanted to copy 9gb file to an 15gb usb 2.0 but transfer speeds always slows down to a halt . tried on ntfs and fat32
my target device supports these 2.
Tried copying from 2 HDD sources.


Try with rsync to copy the file instead of cp or install the package pv which is providing status progress on the copy.

$ rsync -ah --progress source destination


$ pv -pterT source destination

FAT32 does not support files bigger than 4G - so that is bound to fail.

When you use a filesystem which actually supports a file larger than 4G - you must be patient - remember, your system uses RAM as buffer - use your file manager’s safe eject or use sync on the command line to ensure all data is flushed to disk.

NTFS supports files that large - but I think your problem is your usb stick - it maybe worn and teared. You could try to zero the stick completely then reformat using exfat - and retry.

Since you mention NTFS and FAT32 I think portable - if that is not the case but only intended as storage - you could try with f2fs as this is written for flash devices.

I run my system NVME on f2fs - and it is faster than the ext4 equivalent.

If you want to ensure the stick is usable all the way - zero a stick before use

# dd if=/dev/zero of=/dev/sdy bs=4k status=progress

If your stick is worn it will show at some point.

Another method to test your stick is described at F3 by Digirati - and while the test is to detect fradulent suppliers of flash memory - it can also be used to test the flash for errors.

1 Like