FFXI launcher; big Noob, Trying to configure wine for a specific purpose

I am reading and doing my best to follow this reddit threads instructions on how to get ■■■■■■ and FFXI running on my machine. I hear man testimonials of people playing this game on linux but this is the only guide I have found. ■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■

Now I have cloned the wine git linked in the thread in question, but upon doing ./configure it apparently was trying to tell me That I did not have the correct dependencies. I only discovered this after realizing that make, was not working for this reason. Now I’m not sure what these dependencies are, but i do know I need to install them first.

If you have read to this point you probably are aware that I am uneducated in even some of the most basic of konsole useage. So let me say this I am right now willing to go what ever mile this training trip will take me to find out if this Guide will work for my machine. If someone is willing to work with me on this I would be overjoyed. A number of friends are watching to see If I can manage to get on the Game with them and Im sure they would be happy too.

edit: a note it seems the name of the launcher is a censored word That is strange.

I see :poop: in the link if this is what is censored.

Ah Yeah Thats why since it is in the name of the launcher A:poop:a Thank you omano

On a separate note, I use Lutris for everything WINE related, so each individual Windows app is contained in its own WINE prefix folder instead of using globally the system’s WINE with the .wine folder in your Home.

I see there is an install script, I didn’t try but they usually work FINAL FANTASY XI Online - Lutris (basically you install your game in Lutris from the appropriate install script on Lutris website or from a search within Lutris app directly, once installed you can create a desktop icon or start it from Lutris).

Not sure about modding it then.

That is awesome. I saw that item in Lutris myself but it only came up under Steam so I did not try that.

What I am trying tho is trying to use proton 6.3 to run the programs myself and bypass having to use Steam. I got this back

Proton: Upgrading prefix from None to 6.3-3 (/home/bodom/.proton//)
Traceback (most recent call last):
File “/home/bodom/.steam/steam/steamapps/common/Proton 6.3/proton”, line 1288, in
g_session.init_session(sys.argv[1] != “runinprefix”)
File “/home/bodom/.steam/steam/steamapps/common/Proton 6.3/proton”, line 1100, in init_session
File “/home/bodom/.steam/steam/steamapps/common/Proton 6.3/proton”, line 654, in setup_prefix
steamdir = os.environ[“STEAM_COMPAT_CLIENT_INSTALL_PATH”]
File “/usr/lib/python3.10/os.py”, line 679, in getitem
raise KeyError(key) from None

You shouldn’t be using Proton outside of Steam. Proton is made for Steam only.

You can use Lutris’ WINE versions or GloriousEggroll’s wine-ge-custom.

Thank you for the quick response. So that is what I am digging up right now actually.


I discovered a pdf guide about getting things running using Proton-GE and im wondering if Proton-GE is the same as wine-ge-custom. Is this the same thing?

Proton-GE only works in Steam. You’d have to use wine-ge-custom instead, which is also by the same person, GloriusEggroll.

You can just use the Lutris installer to make your life more simple.

I do have Steam I was only avoiding so I didnt have to download what I already have. following the guide I found It instructs that I add the launcher to Steam and run Proton-GE from it. As I am so unfamiliar with these terms and facts You are very helpful. Thank you.

So here is my new road block

This guide is written for debin, which has been fine but this point might be a problem
The guide shows this

$ env
ST/dist/bin/wine64" wine ./Installer.exe

I noticed how this starts with a $ , will this work ??

edit: okay no that is not a problem but neither the file nor folder pfx is working and i dont know why I can only guess it has something to do with this guide being a little bit out of date

Not tried this myself as i run Crossover so don’t need it, but you could try “Bottles”

You can build it from AUR as well.

Thank you very much. This is a very interesting program, I would like to try it the only thing being I am so close to completing the last step in this guide. If I can get this command to work The installation window should pop up. So Im going to look around and try to find out why the command is not working if I cant get past this point I will look into Bottles.

Try simply that WINEPREFIX="path/to/wine/prefix/folder" WINEPATH="/path/to/wine/installation/folder" wine ./Installer.exe in terminal

Thank you, That is great advice but what was actually was wrong was I needed a different path for the Wine Prefix as the guide being just alittle out of date made a big difference in the pathing after I figured that out. It installed. Now to see if it will play.

So what happened is I ended up Installing this a bunch of times but it kept, failing? So I followed some advice I found, to Install it via wine in a Wine directory and copy the files over to the proper steam folder. I did that but then realized That ever single install attempt that failed still ate into my hard drive space. Now I really need help I can not figure out where these files are that are taking up the space. I can not find them to delete them. Its like It installed nothing but still took up space.

Got to crash now Hope I didnt mess up too badly this time.

I have been trying Bottles now. And Its much of the same problems it wont run. Im not completely out of things to try of course and I am impressed in Bottles. I just really want to get this working to join my friends and I am fairly sure there is a correct way to do this but because of some login or net code that I thought Wine Mono would handle its not working or something.

Im sure there is a correct way to troubleshoot though this but I dont have the experience or information to know what is hampered at what point.

But Thank you for showing me this very well done app in Bottles.

Have you used the Lutris installer as mentioned earlier in this thread…?

I guess that would work, but I also realized that it wouldn’t fix the modding part of the game after the game is installed and working, as what he wants to achieve is to install all his mod packs.

But I would still try it. Lutris can provide various flavors of WINE (Glorious Eggroll, Proton, their owns…) and maybe with all the recent improvements since your guide has been written, it may simply work without too much hassle with one of these WINE version you can select to install in Lutris (left menu, Runners → WINE → Manage Versions).

Once the game is installed you can simply run another installer if needed (patch, mod pack, whatever) in its prefix with the WINE menu at the bottom when you select your game in Lutris (Run EXE inside WINE prefix).

Okay I’m going to try and provide all the information That I can.
The version of Final Fantasy XI I am installing is a custom version for a Private server that brings back a classic experience.

so Reports say that getting these newer versions of Ashi ta.exe working is not viable, or maybe it is possible everyones testimonial reads alittle different. I hear the easiest way is to directly use injector.exe and connect to the server that way. The main problem with connecting to this private server in particular i am told is .NET 4.5 but just like how a small percentage of people seem to beable to run older version of Ashi ta a small percentage of people seem to beable to overcome the .NET 4.5 hurtle.

Each time I run the injector.exe in wine I get an error and says config.xml I dont know if it wants a config.xml The xml’s are located in the config folder but all have different names.


Running things though GE-Proton on Steam had similar failures. Either not starting or showing this same box each time.

Bottles showed similar results of just giving up after trying.

And now on Lutris, Ive been trying different versions of the wine that came with it, and each time it just says its Running but never gives me anything after updating the wine prefix’s but it never completely knows when to stop it just says Running so i Stop it manually. The installer seems to work just fine and installs all the files but getting it running beyond this point even tho others have succeeded I have not learned yet what will work.

So If i want to go back to Wine-staging 6.22 how do I do that do I need to unistall wine 7