Fehlermeldung beim Update: Abhängigkeiten

Hallo,
beim Updaten via GUI erhalte ich die Fehlermeldung “Kann Abhängigkeiten nicht erfüllen, …kdewebkit entfernen”
Auf der Kommandozeile: “Entfernen kann nicht durchgeführt werden, verletzt Abhängigkeiten”
Und pacman -Syu gibt

Fehler: Vorgang konnte nicht vorbereitet werden (Kann Abhängigkeiten nicht erfüllen)
:: Installation von kcmutils5 (5.111.0-1) verletzt Abhängigkeit »kcmutils«, benötigt von basket
:: Installation von kfilemetadata5 (5.111.0-1) verletzt Abhängigkeit »kfilemetadata«, benötigt von basket
:: Installation von kparts5 (5.111.0-1) verletzt Abhängigkeit »kparts«, benötigt von basket
:: Installation von kholidays5 (1:5.111.0-1) verletzt Abhängigkeit »kholidays«, benötigt von kalarmcal
:: Installation von kparts5 (5.111.0-1) verletzt Abhängigkeit »kparts«, benötigt von kdewebkit
:: Installation von kpeople5 (5.111.0-1) verletzt Abhängigkeit »kpeople«, benötigt von kpeoplevcard
:: Installation von kcontacts5 (5.111.0-1) verletzt Abhängigkeit »kcontacts«, benötigt von kpeoplevcard
:: Installation von kxmlgui5 (5.111.0-1) verletzt Abhängigkeit »kxmlgui«, benötigt von libkipi
:: Installation von kservice5 (5.111.0-1) verletzt Abhängigkeit »kservice«, benötigt von libkipi
:: Installation von plasma-framework5 (5.111.0-1) verletzt Abhängigkeit »plasma-framework«, benötigt von nx-clock-applet
Blockquote

Wie kann ich updaten?
Danke
Michael

Hallo @michiq_de :wink:

Scheint, dass du du ne menge Pakete aus der AUR installiert hast, die jetzt nicht mit den offizellen Paketen harmonieren. Oder diese wurde in die AUR verschoben?

Die Pakete, die du entweder ersetzen oder entfernen musst, sind, die erwähnt werden bei “benötigt von Paketname”.

Versuch mal erst:

pamac update --enable-downgrade --no-aur
1 Like

Danke,
Problem gelöst. Ich habe die Abhängigkeiten mit
“pacman -R”
gelöscht. Das musste ich mehrmals machen, weil immer wieder andere Dateien angezeigt wurden.
Anschließend lief
“pacman -Syu” problemlos durch.

Hi megavolt,

Dankeschön für deinen Tipp mit:
pamac update --enable-downgrade --no-aur

Hat Prima geklappt.