Fehlermeldung bei sudo -i

Hallo zusammen,

ich habe zu diesem Fehler leider nichts gefunden und versuche es daher auf diesem Weg:
Ich habe eine frische Manjaro Installation (18.0.3 mit XFCE Umgebung) und bekomme bei jedem “sudo -i” eine Fehlermeldung:

** (flatpak:2200): CRITICAL **: 20:56:06.909: Failed to get connection to xfconfd: Fehler beim Erzeugen der Befehlszeile »dbus-launch --autolaunch=65a5ce7c36764de788a6da91a33a14e2 --binary-syntax --close-stderr«: Der Kindprozess wurde mit Status 1 beendet

Die Root-Shell steht aber trotzdem zur Verfügung und auch das environment scheint geladen zu sein.
Es macht keinen Unterschied ob sudo über tty oder über die gui gestartet wird.

Mit sudo -s kommt der Fehler nicht… Es liegt also am geladenen environment: Wenn ich die Zeile 7 in /etc/profile.d/flatpak.sh auskommentiere :

     7         # flatpak --installations

ist die Fehlermeldung weg.

Für mich ist jetzt die Frage: Was könnte an meiner Installation schief sein? Ich glaube nicht, dass es ein Bug ist. Das wäre ja schon jemand anderem aufgefallen :slight_smile:

Viele Grüße
Helge

Also wenn ich die root-shell direkt im tty2 starte, dann erhalte ich bei dem Befehl flatpak --installations nicht die oben genannte Fehlermeldung.
Das erklär ich mir, weil xfconfd im tty2 ja keine Rolle spielt. Weiter bringt es mich aber nicht, außer dass es irgendwie mit xfce zusammenhängt!?

Kann jemand von euch bestätigen diesen Fehler auch zu bekommen?

Hallo der.helge,

In meinem xfce-Manjaro kommt dieser Fehler nicht. Ich habe auch keine Antwort, sondern unbeliebterweise nur eine Gegenfrage:
Wozu brauchst Du
sudo -i
in diesem Zusammenhang? Es geht ja offenbar irgendwie um Flatpak-Installation, reicht da nicht für systemweite Installation ein schlichtes
sudo flatpak install --from URL
bzw. nur für den User ohne sudo.
Um Missverständnisse zu vermeiden, es gibt sicher Sachen, bei denen man sudo -i braucht, nur reicht meine Phantasie nicht aus, um eine konkrete Anwendung zu nennen.
Das wäre aber vielleicht hilfreich, um eine Antwort auf dein Problem zu finden.
Und wie Du schon sagtest, meine Vermutung geht ebenfalls stark in Richtung Environment, je nach login-Shell oder Non-Login-Shell.
Wie gesagt, keine Antwort, aber ein Versuch, etwas Schwung in die Sache zu bringen.

viele Grüße gosia

1 Like

Hallo gosia,

ich will das gar nicht aufrufen aber es steht in /etc/profile.d/flatpak.sh und wird daher bei jedem Aufruf von sudo -i aufgerufen. Vielleicht habe ich mich da missverständlich ausgedrückt.

Aber es ist schon einmal gut zu wissen, dass die Fehlermeldung bei dir nicht kommt. Dann ist es kein genereller Bug.

Viele Grüße

Hallo der.helge,

/etc/profile.d/flatpak.sh existiert bei mir gar nicht, ich benutze aber auch kein flatpak. Daher die Frage: Was hast du mit flatpak installiert? Außerdem kann ich mich @gosia anschließen, wozu brauchst du die -i Option? Ich vermute mal, dass irgendwas mit flatpak xfconfd benötigt, sieht dass der läuft aber nicht auf den dbus zugreifen kann, da sudo -i eine neue login Umgebung lädt o.ä.

Viele Grüße

Hallo gosia, ich verwende z.b. sudo -i wenn ich eine root shell brauche bzw. verwenden möchte, da ich den root login deaktiviert habe

May be this helps: Sudo tilix with xfconfd error in gnome

Hallo vetzki,

Ok, aber in dem Fall bevorzuge ich Strg+Alt+Fn, um auf eine Textconsole zu kommen und mich dort als root anzumelden. Aber gut, viele Wege führen nach Rom.
Die von mbod gezeigte Lösung


kommt jedenfalls auch ohne die Option -i aus.

viele Grüße gosia

ich kann mich wiegesagt nicht als root anmelden und “muss” dann falls ich eine root shell möchte sudo -i verwenden.

Es war mehr eine Antwort auf die Frage wegen der konkreten Anwendung und nicht wirklich auf die/das eigentliche Frage/Problem bezogen

Hallo zusammen,

danke für die vielen Antworten :slight_smile:

@gosia: sudo -i startet eine interaktive login shell. Das kann man schon mal gebrauchen :slight_smile: der bei mbod benutzte Befehl braucht keine login-shell, sondern soll lediglich soll er den dahinter stehenden Befehl als root ausführen.

@firefightux: Interessant… Ich dachte flatpak wäre im Auslieferungszustand von Manjaro 18 dabei? In meinem pacman.log sehe ich zumindest nicht, dass ich es installiert hätte. Ich brauch es eigentlich auch nicht. Klar kann ich flatpak.sh einfach löschen oder das Paket entfernen. Aber dann weiß ich immer noch nicht wieso das eigentlich passiert ist.

@mbod: thanks for your advice. unfortunately it makes no difference:

[turek ~]# flatpak --installations

** (flatpak:1748): CRITICAL **: 15:19:00.723: Failed to get connection to xfconfd: Fehler beim Erzeugen der Befehlszeile »dbus-launch --autolaunch=65a5ce7c36764de788a6da91a33a14e2 --binary-syntax --close-stderr«: Der Kindprozess wurde mit Status 1 beendet
/var/lib/flatpak
[turek ~]# 

Laut http://rwthaachen.dl.osdn.jp/storage/g/m/ma/manjaro/xfce/18.0.3/manjaro-xfce-18.0.3-stable-x86_64-pkgs.txt ist flatpak 1.2.3-1 im Auslieferungszustand dabei. Erstaunlich alles :smiley:

Da ich keinen Grund gesehen habe, warum flatpak installiert sein sollte, habe ich flatpak deinstalliert…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark