有人用 fcitx 的快速倉頡輸入法的嗎?

我用的是 fcitx 快速倉頡第六代。目前最困擾我的問題是打字的時候他顯示的是英文字母而非倉頡碼(如:『我』的倉頡碼是『竹手戈』但打字時顯示的卻是hqi。)不知是否有人能建議如何設定 fcitx 讓他顯示倉頡碼而非英文字母呢? 謝謝。
以下是 fcitx-diagnose 的輸出:

Summary
# 系統資訊:
1.  `uname -a`:

        Linux Tu-PC 4.19.32-1-MANJARO #1 SMP PREEMPT Wed Mar 27 18:55:07 UTC 2019 x86_64 GNU/Linux

2.  `lsb_release -a`:

        LSB Version:    n/a
        Distributor ID: ManjaroLinux
        Description:    Manjaro Linux
        Release:        18.0.4
        Codename:       Illyria

3.  `lsb_release -d`:

        Description:    Manjaro Linux

4.  `/etc/lsb-release`:

        DISTRIB_ID=ManjaroLinux
        DISTRIB_RELEASE=18.0.4
        DISTRIB_CODENAME=Illyria
        DISTRIB_DESCRIPTION="Manjaro Linux"

5.  `/etc/os-release`:

        NAME="Manjaro Linux"
        ID=manjaro
        ID_LIKE=arch
        PRETTY_NAME="Manjaro Linux"
        ANSI_COLOR="1;32"
        HOME_URL="https://www.manjaro.org/"
        SUPPORT_URL="https://www.manjaro.org/"
        BUG_REPORT_URL="https://bugs.manjaro.org/"

6.  桌面環境:

    桌面環境為 `kde`。

7.  Bash 版本:

        BASH_VERSION='5.0.0(1)-release'

# 環境:
1.  DISPLAY:

        DISPLAY=':0'

2.  鍵盤配置:

    1.  `setxkbmap`:

            xkb_keymap {
                xkb_keycodes  { include "evdev+aliases(qwerty)" };
                xkb_types     { include "complete"      };
                xkb_compat    { include "complete"      };
                xkb_symbols   { include "pc+au+inet(evdev)+terminate(ctrl_alt_bksp)"    };
                xkb_geometry  { include "pc(pc105)"     };
            };

    2.  `xprop`:

            _XKB_RULES_NAMES(STRING) = "evdev", "pc105", "au", "", "terminate:ctrl_alt_bksp"

3.  地區設定:

    1.  全部地區設定:

            C
            en_AU.utf8
            en_US.utf8
            POSIX
            zh_TW.utf8

    2.  目前地區設定:

            LANG=zh_TW.UTF-8
            LC_CTYPE="zh_TW.UTF-8"
            LC_NUMERIC=en_AU.UTF-8
            LC_TIME=en_AU.UTF-8
            LC_COLLATE="zh_TW.UTF-8"
            LC_MONETARY=en_AU.UTF-8
            LC_MESSAGES="zh_TW.UTF-8"
            LC_PAPER=en_AU.UTF-8
            LC_NAME=en_AU.UTF-8
            LC_ADDRESS=en_AU.UTF-8
            LC_TELEPHONE=en_AU.UTF-8
            LC_MEASUREMENT=en_AU.UTF-8
            LC_IDENTIFICATION=en_AU.UTF-8
            LC_ALL=

4.  目錄:

    1.  家目錄:

            /home/o0331dobe

    2.  `${XDG_CONFIG_HOME}`:

        環境變數 `XDG_CONFIG_HOME` 未設定。

        `XDG_CONFIG_HOME` 目前的值為 `~/.config` (`/home/o0331dobe/.config`)。

    3.  Fcitx 設定目錄:

        目前的 fcitx 設定目錄為 `~/.config/fcitx` (`/home/o0331dobe/.config/fcitx`)。

5.  目前使用者:

    此腳本以 o0331dobe (1000) 執行。

# Fcitx 狀態:
1.  可執行檔:

    在 `/usr/bin/fcitx` 找到 fcitx。

2.  版本:

    Fcitx 版本:`4.2.9.5`

3.  程序:

    找到 2 個 fcitx 程序:

         1157 fcitx
         1207 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` 運作正常。

5.  DBus 介面:

    Using `dbus-send` to check dbus.

    Owner of DBus name `org.fcitx.Fcitx` is `:1.39`.

    PID of DBus name `org.fcitx.Fcitx` owner is `1157`.

# Fcitx 設定介面:
1.  設定工具封裝:

    在 `/usr/bin/fcitx-configtool` 找到 fcitx-configtool。

2.  gtk2 的設定介面:

    **找不到 gtk2 的設定介面。**

3.  gtk3 的設定介面:

    **找不到 gtk3 的設定介面。**

4.  KDE 的設定介面:

    **找不到 `kcmshell4`。**

    **找不到設定介面,請安裝 `kcm-fcitx`、`fcitx-config-gtk2` 或 `fcitx-config-gtk3` 其中之一。**

# 前端設定:
## Xim:
1.  `${XMODIFIERS}`:

    **XMODIFIERS 未設定**

    **請設定環境變數 XMODIFIERS 到「@im=fcitx」,使用您的發行版提供的工具或加入 `export XMODIFIERS=@im=fcitx` 到您的 `~/.xprofile`。請參閱 [輸入法相關環境變數:XMODIFIERS](http://fcitx-im.org/wiki/Input_method_related_environment_variables#XMODIFIERS)。**
    環境變數中 XIM 服務名稱為 fcitx。

2.  root 視窗上的 XIM_SERVERS:

    Xim 服務的名稱與環境變數的設定相同。

## Qt:
1.  qt4 - `${QT4_IM_MODULE}`:

    環境變數 QT_IM_MODULE 正確地設定為「fcitx」。

2.  qt5 - `${QT_IM_MODULE}`:

    環境變數 QT_IM_MODULE 正確地設定為「fcitx」。

3.  Qt 輸入法模組檔案:

    找到了 Qt4 的 fcitx 輸入法模組:`/usr/lib/qt4/plugins/inputmethods/qtim-fcitx.so`。
    找到了 Qt5 的 fcitx 輸入法模組:`/usr/lib/qt/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so`。
    找到未知的 fcitx qt 模組:`/usr/lib/qt/plugins/kcm_fcitx.so`。
    找到了 fcitx 的 qt 模組:`/usr/lib/fcitx/qt/libfcitx-quickphrase-editor5.so`。

## Gtk:
1.  gtk - `${GTK_IM_MODULE}`:

    環境變數 GTK_IM_MODULE 正確地設定為「fcitx」。

2.  `gtk-query-immodules`:

    1.  gtk 2:

        在 `/usr/bin/gtk-query-immodules-2.0` 找到 gtk `2.24.32` 的 `gtk-query-immodules`。
        版本:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.32

        找到了 gtk `2.24.32` 的 fcitx 輸入法模組。

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        在 `/usr/bin/gtk-query-immodules-3.0` 找到 gtk `3.24.7` 的 `gtk-query-immodules`。
        版本:

            # Created by /usr/bin/gtk-query-immodules-3.0 from gtk+-3.24.7

        找到了 gtk `3.24.7` 的 fcitx 輸入法模組。

            "/usr/lib/gtk-3.0/3.0.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

3.  Gtk 輸入法模組快取:

    1.  gtk 2:

        在 `/usr/lib/gtk-2.0/2.10.0/immodules.cache` 找到 gtk `2.24.32` 的輸入法模組快取。
        版本:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.32

        找到了 gtk `2.24.32` 的 fcitx 輸入法模組。

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

        在 `/etc/gtk-2.0/gtk.immodules` 找到 gtk `2.24.32` 的輸入法模組快取。
        版本:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.32

        **無法在 `/etc/gtk-2.0/gtk.immodules` 的輸入法模組快取中找到 fcitx**

    2.  gtk 3:

        在 `/usr/lib/gtk-3.0/3.0.0/immodules.cache` 找到 gtk `3.24.7` 的輸入法模組快取。
        版本:

            # Created by /usr/bin/gtk-query-immodules-3.0 from gtk+-3.24.7

        找到了 gtk `3.24.7` 的 fcitx 輸入法模組。

            "/usr/lib/gtk-3.0/3.0.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

4.  Gtk 輸入法模組檔案:

    1.  gtk 2:

        所有找到的 gtk 2 輸入法模組檔案皆存在。

    2.  gtk 3:

        所有找到的 gtk 3 輸入法模組檔案皆存在。

# 設定:
## Fcitx 附加元件:
1.  附加元件設定目錄:

    找到 fcitx 附加元件設定目錄:`/usr/share/fcitx/addon`。

2.  附加元件清單:

    1.  找到 27 個啟用的附加元件:

            fcitx-autoeng
            fcitx-chewing
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-imselector
            fcitx-ipc
            fcitx-ipcportal
            fcitx-keyboard
            fcitx-kimpanel-ui
            fcitx-notificationitem
            fcitx-pinyin
            fcitx-pinyin-enhance
            fcitx-punc
            fcitx-quickphrase
            fcitx-remote
            fcitx-spell
            fcitx-table
            fcitx-unicode
            fcitx-vk
            fcitx-x11
            fcitx-xim
            fcitx-xkb
            fcitx-xkbdbus

    2.  找到 1 個停用的附加元件:

            fcitx-qw

3.  附加元件函式庫:

    找到了所有附加元件的函式庫。

4.  使用者介面:

    找到 2 個啟用的使用者介面附加元件:

        fcitx-classic-ui
        fcitx-kimpanel-ui

## 輸入法:
1.  找到 3 個啟用的輸入法:

        fcitx-keyboard-au
        scj6
        chewing

2.  預設輸入法:

    您使用鍵盤輸入法 fcitx-keyboard-au,正確加入作為您的預設輸入法。

# 日誌:
1.  `date`:

        Wed Apr  3 18:26:11 AEST 2019

2.  `~/.config/fcitx/log/`:

        總計 4
        -rw-r--r-- 1 o0331dobe o0331dobe 44 Feb 21 11:11 crash.log

3.  `~/.config/fcitx/log/crash.log`:

        fcitx: BadWindow (invalid Window parameter)

还不知道仓颉是蛤。。。:joy::joy::joy:

聽說跟五筆有點像(沒用過五筆不確定)。好處是知道字怎麼寫就能打得出來,所以說用久了中文不會退步呀。:rofl:
大新倉頡還曾坐過一陣子中打最速輸入法的寶座。

想多瞭解關於倉頡輸入法的話下方帖子中劉白的回覆我覺得挺值得參考的


離題了 :stuck_out_tongue_closed_eyes:

我在使用 ibus 的五笔输入法,可以确认输入时显示的是中文汉字而不是英文字母的,fcitx 没用过不清楚
可以加 archlinuxcn 群组 https://telegram.me/archlinuxcn 或者 IRC: archlinux-cn @ freenode,里面的人都超级活跃的~应该有使用仓颉输入法的用户

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.