Fcitx can't change input method in some programs

Hey, does anyone here have experience working with Fcitx? I currently have a few languages in it, but I noticed that when I'm typing in Kate, or Libre Writer, my shortcut for changing the input language doesn't work. Even if I set the input directly through Fcitx's icon in the system tray and it works in other windows like my browser, it still only uses English in Kate, Libre Writer, and some others I've come across.

Any idea what causes this?

This might be helpful:

https://fcitx-im.org/wiki/FAQ

I've already gone through it, I didn't find anything that could help.

I'm starting to think it's not just those programs, the problem is that fcitx just doesn't work with KDE or something. I tried opening its virtual keyboard with ordinary latin letters, and the keyboard worked in my browser, but not in my desktop.

Yup, now that I know what to search for, I found a few other threads in these very forums with the same problem and it turns out I needed to create a file ~/.pam_environment with these contents

GTK_IM_MODULE=fcitx
QT_IM_MODULE=fcitx
XMODIFIERS=@im=fcitx
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark