Fault in Package Manager GUI

Hello all,

The problem TLDR; The add/remove software gui is currently only displaying installed packages.

I’ve done a bit of forum surfing for the last few hours and can’t find any details on this precise problem. I’ve been using Manjaro on an old computer for a while now without issues and finally decided to make it my standard OS on my workstation laptop. I just finished a fresh install with the latest Plasma desktop ISO verified against the checksum value on a known good USB (error checked at media creation because I don’t like surprises).

All I’ve done thus far is do a manual build of my favorite password manager, and changed the desktop theme to breeze dark. I believe it could be the second action that caused the problems I’m seeing although that is supposition.

I have refreshed the databases, checked that the pacman config includes the proper database locations and configuration. I can find no errors in the file. Everything looks to be properly default. In fact refreshing the databases and swapping in and out of software mode appears to be populating just fine and doesn’t return any error messages. The processes complete without issue and it reports I am up to date. The only thing I’ve been able to find is the following error message in the logs during a database refresh operation:

4/25/23 9:22 PM user@1000.service manager_window.vala:2450: /usr/share/app-info/icons/archlinux-arch-(null)/64x64/ark_ark.png: Failed to open file “/usr/share/app-info/icons/archlinux-arch-(null)/64x64/ark_ark.png”: No such file or directory

Note the “archlinux-arch-(null)” which I already know isn’t a directory. There are 9 such errors in the log, all pointing at a different icon. The nearest I can figure is that there is some sort of conflict going on that is making the gui look for an icon under that directory. The program tries to find those icons, faults, and as a result it displays nothing. I’ve been trying to find out where there would be a null value and coming up empty handed. If anyone has any ideas as to what’s going on, I would be grateful.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

It sounds like a good next step would be to verify this theme supposition by changing themes.

I’ve tried that. I changed the theme back to default and then to default version dark mode. I think it’s called breath. No effect even with a full restart to ensure all changes go into effect.

Well after several hours of trying to grep the locations of pacman files that might be indicating a reference to an archlinux repo with a null value for the versioning without any success because I know nothing about the backend file structure. I switched gears and double checked the installation media has the same issue. It doesn’t. I opted to reinstall fresh and keep the theme default this time. No issues thus far.

You didn’t gave any clue on which desktop environment you’re at. Plasma, Gnome, XFCE, something else … Changing themes is always one thing, but shouldn’t affect pamac. You can also use it from a terminal, similar to pacman.

pamac update --force-refresh

would try to do a system update and refreshes the databases before. You could cancel the update process and try with pamac search <pkgname> to see if you find some packages you’re looking for. As alternative there is also octopi, gnome-software, discover and many more graphical UIs for package management.

1 Like

That icon is part of archlinux-appstream-data. Try reinstalling it:

sudo pacman -Syu archlinux-appstream-data

Look again at the third line of the first major paragraph :slight_smile: I did mention it was the plasma desktop. I am aware of the alternative package managers and I’m pretty well versed in terminal commands for pacman which all still worked.

I apologize if this comes across as a non issue. Mostly I prefer to understand a problems source though and fix it if I can. I also wasn’t sure if this could be indicative of an issue with Plasma or some sort of installation error. I’ll admit I just like the aesthetics of this particular package manager and desktop. I want to use it, just not sure what could have caused it to not display uninstalled packages when I changed themes.

I also said I “fixed” it last night by reinstalling the entire OS from scratch. The error is still present in the log even though its working so I’m now at an even bigger loss as to what faulted where the first time through. I would attempt to replicate it but now I’m concerned no one really gives a damn about the results of that other than me xD

I tried this and it reinstalled cleanly. I then loaded the package manager and the logs to see if the errors were still present and they weren’t. Then out of curiosity I changed themes to see if it would fault in the same way and it did not.

I now have the theme I want and it didn’t break the package manager. Could be indicative that the appstream-data is somehow corrupted in the base installation? Idk, take from it what you will but I am happy. Thank you for the help.

Alright, this will be my final post because I wanted to identify what changed to find out the source of the problem. I can’t help myself sadly. I spun up a VM with the same ISO file on my main machine. Confirmed it contained the same problems and played with it a bit to see what the cause was and what fixed it.

An update to the manjaro-log-helper package is what fixes it. An update that was released after my initial install. I’ve confirmed it with 4 variations of steps from a fresh install. I have no idea why but the package manager is broken before that log helper update and works after.

Although reinstalling the archlinux-appsteam-data packages does still address the log errors for finding icons at null directory locations so that’s cool I suppose.

That is indeed odd.
I know what update you are referring to … and its just one line fixing the method for sending to dpaste. Oh and a quick change to rename dialogs to reflect dpaste instead of ubuntu destination.
How on earth that breaks theme/pamac … eludes me.

What happens if manjaro-log-helper is de-installed? Can then the GTK3 theme been changed? Also did you tried the developer version of pamac which is a port to GTK4?

Your guess is as good as mine. I don’t know the source code in the slightest but I was just as confused why it would have an impact on this problem.

I didn’t test either of these scenarios but I still have the VM loading off the base ISO file. I’ll test it out and report back when able. Also, just in case anyone wants to confirm these findings or test themselves, the ISO I’m working off of with this issue is:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.