Fans overworking and laptop won't shut down.

This morning my fans started overworking as I was using my laptop. Used systemctl reboot to reboot, fans were still going, so I did a full shutdown. My laptop came right back on. Using the power button does the same thing. It stays off as long as I hold it, but will come back on to the ASUS startup and GRUB screens like normal when I let go.

CPU and RAM loads are normal and my laptop is not hot, just the fans are overworking (not going crazy, but very audible).

Currently running kernel 4.19, booting into 5.3 does not change the outcome. Suspending by closing the lid works fine.

Dropping into TTY and using shutdown now does not work, and there are no error logs in journalctl -rp err -b-1 (from this Reddit post) shutdown -h now yields the same results.

Disabling fast boot in BIOS does not work.

Before this, I have rebooted maybe a week ago (or longer)? There have been video driver updates since then, I'm aware.

Laptop: ASUS Vivobook S14
CPU: i7-8550U
GPU: Nvidia GeForce MX150

may you post the output of 'inxi -Fxz'.

$inxi -Fxz

System:    Host: Asus-VivoBook-S Kernel: 4.19.84-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           Desktop: KDE Plasma 5.17.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X411UN v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X411UN v: 1.0 serial: <filter> UEFI: American Megatrends v: X411UN.302 date: 11/29/2017 
Battery:   ID-1: BAT0 charge: 35.2 Wh condition: 35.2/42.1 Wh (84%) model: ASUSTeK ASUS Battery status: Not charging 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 802 3: 800 4: 800 5: 800 6: 800 7: 800 
           8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: intel FAILED: nvidia unloaded: modesetting 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.2.4 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: Corsair USB2.1 Hub type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-2.2:4 
           Sound Server: ALSA v: k4.19.84-1-MANJARO 
Network:   Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: AzureWave driver: r8822be v: kernel 
           port: d000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 715.41 GiB used: 105.15 GiB (14.7%) 
           ID-1: /dev/sda vendor: A-Data model: SU800 size: 476.94 GiB 
           ID-2: /dev/sdb vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB 
Partition: ID-1: / size: 459.50 GiB used: 105.15 GiB (22.9%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 220 Uptime: N/A Memory: 7.67 GiB used: 713.6 MiB (9.1%) Init: systemd Compilers: gcc: 9.2.0 
           clang: 9.0.0 Shell: bash v: 5.0.11 inxi: 3.0.36

well your video-driver updates are crap, they are broken. your power-management is also. you could try to fix all this but honestly, i would download a actual iso and do a complete reinstall. saves time and stress.

Could you explain how they're broken? I just do regular updates.

Display: x11 server: X.Org 1.20.5 driver: intel FAILED: nvidia unloaded: modesetting 
           resolution: 1920x1080~60Hz 

no i can not explain, because this is a question you have to ask to the developers. it's simple fact that your install went wrong.

I see, thank you for your help.

bit premature, dont ya think?

her laptop was functioning fine until recently if i understand correctly, so this is in fact not a fact.

this is a windows style troubleshooting, "it broke, how fix?" "reinstall, then reinstall again, plan another in a week" :man_facepalming:

@MyahE nothing suggests you need to reinstall, is something going wrong with the nvidia drivers? yes, still not a reinstall situation, drivers take a minute to uninstall and reinstall.

probably but more info is needed. first run an update again to make sure nothing failed to update last time.

sudo pacman-mirrors -f8
sudo pacman -Syyu

if there are any errors, please post along with these outputs

mhwd -li
ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
ls -la /etc/modprobe.d ; cat /etc/modprobe.d/*.conf
ls -la /etc/modules-load.d ; cat /etc/modules-load.d/*.conf

your bios are also fairly old, the latest are from a few months ago and it's in .310 format so you should be able to put it on a usb drive and load it from bios settings.

the hardware button failing to power down the laptop points to something more than video drivers or anything OS controlled for that matter, update the bios.

6 Likes

I can't tell you how much I appreciate your replies!

The problem went away on its own, so I haven't done anything to remedy the situation since I posted this - I don't want to take the chance of making my laptop unusable right now with finals coming up.

I don't have the chance to update my BIOS at the moment of writing this so I'll update when I can.

No errors updating, but here are the outputs anyway:

$mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-430xx-bumblebee            2019.10.25               false            PCI

I switched back to bumblebee after my tussle with my drivers because I needed battery foremost.

$ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
/etc/X11:
total 52
drwxr-xr-x   5 root root  4096 Jun 23 11:16 .
drwxr-xr-x 108 root root 12288 Nov 25 10:16 ..
drwxr-xr-x   2 root root  4096 Aug 25 17:25 mhwd.d
drwxr-xr-x   3 root root  4096 Mar 12  2019 xinit
-rw-r--r--   1 root root  1991 Jun 23 11:16 xorgbackup
-rw-r--r--   1 root root  1755 Jul 31 18:49 xorg.conf
-rw-r--r--   1 root root  1413 Jun 23 03:25 xorg.conf.backup
drwxr-xr-x   2 root root  4096 Aug 25 17:25 xorg.conf.d
-rw-r--r--   1 root root     0 Jun 23 00:00 xorg.conf.nvidia-xconfig-original

/etc/X11/mhwd.d:
total 16
drwxr-xr-x 2 root root 4096 Aug 25 17:25 .
drwxr-xr-x 5 root root 4096 Jun 23 11:16 ..
-rw-r--r-- 1 root root  581 Aug 25 17:25 intel.conf

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 Mar 12  2019 .
drwxr-xr-x 5 root root 4096 Jun 23 11:16 ..
-rw-r--r-- 1 root root  739 Mar  4  2019 xinitrc
drwxr-xr-x 2 root root 4096 Oct 28 14:19 xinitrc.d
-rw-r--r-- 1 root root   45 Mar  4  2019 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 Oct 28 14:19 .
drwxr-xr-x 3 root root 4096 Mar 12  2019 ..
-rwxr-xr-x 1 root root  318 Nov  9  2018 40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 Oct 21 05:27 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 20
drwxr-xr-x 2 root root 4096 Aug 25 17:25 .
drwxr-xr-x 5 root root 4096 Jun 23 11:16 ..
-rw-r--r-- 1 root root  266 Jun  8 13:10 00-keyboard.conf
lrwxrwxrwx 1 root root   26 Aug 25 17:25 90-mhwd.conf -> /etc/X11/mhwd.d/intel.conf
-rw-r--r-- 1 root root  483 Aug 25 17:19 99-nvidia.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"
EndSection
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
Section "Device"
    Identifier  "Device0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
    Option      "AccelMethod" "sna"
        Option      "DRI"    "true"
EndSection
 
 
Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
 
#/etc/X11/xorg.conf.d/99-nvidia.conf
#adjust BusID to match your nvidia GPU
#uncomment and edit the DPI option as needed
#to fix scaling issues.


Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver  "nvidia"
    BusID   "PCI:1:0:0"
    #Option  "DPI" "96 x 96"    #adjust this value as needed to fix scaling
    Option  "AllowEmptyInitialConfiguration"
EndSection

Section "Extensions"
    Option  "Composite" "Enable"
EndSection
$ls -la /etc/modprobe.d ; cat /etc/modprobe.d/*.conf
total 40
drwxr-xr-x   2 root root  4096 Aug 25 17:25 .
drwxr-xr-x 108 root root 12288 Nov 25 10:16 ..
-rw-r--r--   1 root root   150 Aug 25 17:19 99-nvidia.conf
-rw-r--r--   1 root root   105 Aug 25 17:25 mhwd-bbswitch.conf
-rw-r--r--   1 root root   194 Aug 25 17:25 mhwd-nvidia.conf
-rw-r--r--   1 root root    23 Jun 11 16:22 r8822be.conf
-rw-r--r--   1 root root    23 Jun 11 13:33 r8822be.config
#
#necessary blacklist and
#nvidia_drm modeset for nvidia/prime
#

blacklist nouveau
blacklist nvidiafb
blacklist rivafb
options nvidia_drm modeset=1
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
options bbswitch load_state=0 unload_state=0
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
blacklist nouveau
blacklist nvidia
blacklist nvidia-modeset
blacklist nvidia-uvm
blacklist ttm
blacklist drm_kms_helper
blacklist drm
options r8822be aspm=0


$ls -la /etc/modules-load.d ; cat /etc/modules-load.d/*.conf
total 44
drwxr-xr-x   2 root root  4096 Nov 25 10:15 .
drwxr-xr-x 108 root root 12288 Nov 25 10:16 ..
-rw-r--r--   1 root root    67 Aug 25 17:19 99-nvidia.conf
-rw-r--r--   1 root root    38 Nov 16 07:13 linux316-virtualbox-host-modules.conf
-rw-r--r--   1 root root    38 Nov 21 06:59 linux414-virtualbox-host-modules.conf
-rw-r--r--   1 root root    38 Nov 11 15:09 linux419-rt-virtualbox-host-modules.conf
-rw-r--r--   1 root root    38 Nov 21 07:09 linux419-virtualbox-host-modules.conf
-rw-r--r--   1 root root    34 Oct 21 17:08 modules.conf
##
##loads necessary modules for nvidia gpu
##
 
nvidia
nvidia-drm
vboxdrv
vboxnetadp
vboxnetflt
vboxpci
vboxdrv
vboxnetadp
vboxnetflt
vboxpci
vboxdrv
vboxnetadp
vboxnetflt
vboxpci
vboxdrv
vboxnetadp
vboxnetflt
vboxpci
# List of modules to load at boot


your welcome, you have some cleaning to do when you get some time, right now it looks like you have bumblebee and optimus-switch installed, conflicting xorg configurations, and im surprised your even able to get to a desktop but since it's working and you dont want to rock the boat right now you could leave it i guess with the sidenote that if anything goes wrong you know where to look.

it's easily fixed though.

sudo systemctl disable bumblebeed
sudo mhwd -r pci video-hybrid-intel-nvidia-430xx-bumblebee
sudo pacman -S xf86-video-intel xorg-xrandr
sudo mhwd -i pci video-nvidia-430xx
sudo rm -rf /etc/X11/xorg.conf.d/90-mhwd.conf
sudo rm /etc/modprobe.d/mhwd-gpu.conf
sudo rm /etc/modules-load.d/mhwd-gpu.conf

then set nvidia mode and reboot
sudo set-nvidia.sh

Maybe OP prefers bumblebee... :stuck_out_tongue_winking_eye:

There is also this for deletion

/etc/X11/xorg.conf
1 Like

you have a point, some folks do enjoy that sort of thing. i wonder the "safe word" would be? :face_with_hand_over_mouth:

1 Like

I don't enjoy bumblebee, honestly, but I've had too much trouble in the past.

1 Like

the problem with having both installed is that they conflict with each other. those commands i posted should get the video configuration straightened out. possibly also the fan issue if it's caused by something related but since you want to hold off on any changes until after finals thats kind of an unknown.

i guess for now just check htop an see if anything is using more resources than it should, check your temps with sensors and check logs for anything that shouldnt be there

journalctl -b0 -p3
2 Likes

Everything is normal now, it "fixed" itself, but the incident I posted about just revealed how broken my system is.

I have a holiday break starting tomorrow so I'll work on fixing and cleaning up this week. I suppose this is how I learn how to maintain my system better :woman_shrugging:

I'll get back to you on how it goes (and may have questions, if you don't mind). Thank you!

2 Likes

i dont mind, hope it works out. :+1:

I'm back! I updated my BIOS and haven't done anything with the rest of my system. So I found a few interesting things:

  • Unplugging my laptop allows it to shut down (so when not charging).
  • Closing my lid in fact does not work correctly - the screen turns off for a few seconds and comes back on while the lid is still closed.
  • Shutting down from Win10 also does the same thing! Turns right back on.

Seems you're right about this not being an OS problem, but I truly don't know where to go from here.

see if there are sleep/suspend behavior settings in bios, and disable wake on lan and wake on usb.

Wow, I see absolutely nothing for any of that. I have "wake on lid open" and that's it.

Even when searching online for where it could be, I was taken back to this thread before I found anything on my own motherboard.

Forum kindly sponsored by