Fancy "Font-Blocks" after Grub

drivers
systemd
boot
graphics
font

#1

Hello dearest Manjaro-Community! \o/
First i want to say >>THANK YOU<< for making one of the best (arch based) Distros.
You. Are. Great!

Now to my Problem, for which i can’t find a solution (basically because i just don’t know how to name what i see):

At Bootup, right after Grub, instead of normal fonts, i see something like this:


the boot up continues normal.

My first guess would be, that there is something wrong with the unicode settings…
but i have no clue how to fix that.

I have

  • a Lenovo Thinkpad T460s with
  • a KDE-flavoured Manjaro;
  • systemd

thanks for your time :slight_smile:


#2

You need to set correctly the console font.
Choose the correct one for your language and set it in
(wrong:[/etc/console.conf]) /etc/vconsole.conf
after reading this

https://wiki.archlinux.org/index.php/Fonts#Console_fonts


#3

How did you install Manjaro, and which version?
How did you burn the ISO?
Did you verify the checksum?


#4

Hello and thanks for your answers.

I’ve installed Manjaro 17.0.5 KDE Edition via bootable usb-stick (My Notebook has no ODD).

To create the usb-stick i used UNetBootin after verifying the checksum.
For installation, I bootet into the live-OS and used the graphical installer from the welcome-dialog to installed it as my only system on my formated Disk.

At least i set the console font in /etc/vconsole.conf to:

FONT=lat2-16
FONT_MAP=8859-15

the Font is installed and works if changed to it temporary (in tty2) by using
"setfont lat2-16 -m 8859-15"

There is no “console.conf” in /etc/ and the linked article speaks of “vconsole.conf” so i guess that is what @petsam meanet. (Thank you for the link btw.)

Is it possible, that this is just a render-problem while the graphics-driver is not loaded in early starting?

Thanks again for your patience :slight_smile:


#5

Exactly right. My fault on the rush. :zipper_mouth_face:

First, the unetbootin is not the proposed method to create a bootable media.
If it is a media problem then you might have more/other errors with your install and it might be wise to re-install after creating an other media.

If you want to try repairing anyway, there are a lot of laces you could search for troubleshooting.
You may be right with that it may be a VGA driver problem, so you should look in
’/var/log/Xorg.0.log’
for details on font and keymap settings.
In the TTY before changing manually the font did you notice the font was actually wrong as in the boot process?
And read thoroughly the archwiki link and the links. It 's all there and all non-expert users as myself look there first :sunglasses:


#6

That is the problem. Use ‘dd’ or Etcher, Isousb, or Imagewriter in Linux to create reliable USB media.

I would be tempted to start over again, since an installation using Unetbootin may not be tenable. Our ManjaroWiki has further information.

regards


#7

Hey there,
I followed your advice and

  • downloaded the KDE-Edition of Manjaro 17.0.5
  • checked the hash-sum
  • burned the iso to 4 different usb-sticks
  • installed Manjaro to a fresh new formated SSD.
  • testet several language settings (english, german, spanish)

The Result was the same in every case, the “alien-font” still remains.

But one thing makes me wonder, when i bootet from the usb stick, there is this menu were you can set the startup-parameters (language, keymap, drivers[free/nonfree - i testet both]). And this menu was very slow everytime i changed someting and has to “rewrite” itself on every move i made (cursor up/down). I’ll take a picture from it, next time I have a camera by my hands.
For me it looked like the processors graphics card, an Intel HD520 is just not driven up the correct way.

best regards :slight_smile:


#8

HOW are you burning the ISO? Do not use Unetbootin. It is known to cause problems.


#9

Oh sorry I’ve forgotten to mention that, mb. I burned the Images like advised with Suse Studio Imagewriter.


#10

Good stuff. :smiley: Its important to eliminate things like download quality, burning methodology, etc. first. Then it makes trouble-shooting the rest a bunch easier. :smiley:


#11

Thank you. :smiley:
I managed to take a picture of the fancy behaving startup-selection-screen that i see, when i boot from USB.
I know from other machines that this doesn’t look like it should, and it is not an issue with the camera. It realy seems to have reduced graphics here.


#12

Nice boot screen. What are you going to select? Did you know there are a number of tutorials–and youtube videos–that will help you understand what to do next?

regards


#13

I think we are misunderstanding each other here…

That picture above is not something i created, or build.
I don’t seek any help in setting the right boot parameter for the liveboot or something like that and i know there are manuals, tutorials and even videos about installing <insert-your-fav.-Dist.-here> -Linux.

This:
https://raw.githubusercontent.com/manjaro/manjaro-user-guide/master/images/media-boot-screen.png
is how it should look like (with some changes in the menupoints), not like the screen on my photo from the last post.

My guess now would be, that there is a problem in Manjaros pre-configuration, that makes it incompatible with the
Intel® Core™ i7-6600U 's build-in Graphic chip, an Intel® HD Graphics 520. Further more i could imagine, that the same issue results in the fancy block-like looking fonts from my first picture.
And i like to find a way to fix that, since it makes debugging of the system impossible, if it hangs while just showing gibberish.

best regards and again, thanks for your time :slight_smile:


#14

Dear Forum,
my seek for answers is at an dead end here, since nobody seems to have an answer, or is willing to read the description attentively this threat can, despite the problem still exists , be closed.
Thanks for your time.


#15

Since you bring up the “Manjaro preconfiguration part”, did you tried with the hakoila iso?.


#16

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.