Fancontrol i8kutils service doesn't start at boot

Hi,
i am using dell-bios-fan-control and i8kutils to control the fans of my Dell XPS laptop.

Already done:

sudo dell-bios-fan-control 0
sudo modprobe i8k force=1
systemctl enable i8kmon
systemctl start i8kmon

Works, but after reboot the service fails to start at boot: :face_with_thermometer:

[pappl@pappl-pc ~]$ systemctl status i8kmon
● i8kmon.service - Dell laptop thermal monitoring
   Loaded: loaded (/usr/lib/systemd/system/i8kmon.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
Condition: start condition failed at Wed 2019-04-03 19:33:59 CEST; 1min 38s ago
           └─ ConditionPathExists=/proc/i8k was not met
     Docs: man:i8kmon

Apr 03 19:33:59 pappl-pc systemd[1]: Condition check resulted in Dell laptop thermal monitoring being skipped.

I have to do a
sudo modprobe i8k force=1

and then

systemctl start i8kmon

Then it works:

[pappl@pappl-pc ~]$ systemctl status i8kmon
● i8kmon.service - Dell laptop thermal monitoring
   Loaded: loaded (/usr/lib/systemd/system/i8kmon.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2019-04-03 19:49:33 CEST; 3s ago
     Docs: man:i8kmon
 Main PID: 1839 (tclsh)
    Tasks: 2 (limit: 4915)
   Memory: 3.9M
   CGroup: /system.slice/i8kmon.service
           └─1839 tclsh /usr/bin/i8kmon --nouserconfig

Apr 03 19:49:33 pappl-pc systemd[1]: Started Dell laptop thermal monitoring.

How can i avoid to run
sudo modprobe i8k force=1
after every boot manually without a script doing exactly this command.
Why doesn’t this command survive a reboot?

Please help.
pappl

From what i gathered, the dell-bios-fan-control.service should be also enabled, and will load Before=i8kmon.service
In /etc/modprobe.d/ you should have something like dell-bios-fan-control.conf or i8k.conf with the line:
options i8k force=1

1 Like

This is what i already tried by creating a /etc/modprobe.d/i8k.conf file and adding
options i8k force=1

Does not work (i8k.conf or dell-bios-fan-control.conf)
But the first service is running at boot:

[pappl@pappl-pc ~]$ systemctl status dell-bios-fan-control
● dell-bios-fan-control.service - Disables BIOS control of fans at boot.
  Loaded: loaded (/usr/lib/systemd/system/dell-bios-fan-control.service; enabled; vendor preset: disabled)
  Active: active (exited) since Wed 2019-04-03 21:06:32 CEST; 27s ago
 Process: 386 ExecStart=/usr/bin/dell-bios-fan-control 0 (code=exited, status=0/SUCCESS)
Main PID: 386 (code=exited, status=0/SUCCESS)

Apr 03 21:06:32 pappl-pc systemd[1]: Starting Disables BIOS control of fans at boot....
Apr 03 21:06:32 pappl-pc dell-bios-fan-control[386]: BIOS CONTROL DISABLED
Apr 03 21:06:32 pappl-pc systemd[1]: Started Disables BIOS control of fans at boot..

:confused:

The module in i8k.conf or dell-bios-fan-control.conf doesn’t load at boot and i don’t know how to find a root cause. :frowning:

pappl

Hmm … but you do have in /etc/modules-load.d/ the file dell-bios-fan-control.conf or i8k.conf with the line:
i8k

?

To clarify:

  • In /etc/modprobe.d/ you place the files with the options
  • In /etc/modules-load.d/ you place the files with the actual module name to load.
1 Like

Added i8k.conf to /etc/modules-load.d/ and i8kutils fan control is active after boot.

Insert:

i8k

Save

works
Thank you!
:+1:

pappl

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by