Falkon 'child process' failure

I needed to save space on my laptop so uninstalled Firefox and installed the much smaller Falkon browser. It works fine when I open it from the menu icon, but if I click on a url link in an email I get the following message:
Failed to execute default web browser. Failed to execute child process “Falkon” (no such file or directory).
How can I fix this?
My email client is Thunderbird (though I’d like a much smaller program for this too - any suggestions?

Should have mentioned the laptop is running Manjaro with all latest updates.

Welcome to the Forum!

Open a terminal window and run these commands:

xdg-mime default org.kde.falkon.desktop x-scheme-handler/http


xdg-mime default org.kde.falkon.desktop x-scheme-handler/https

After that links should open in Falkon.

I suspect that you set the name of the executable file incorrectly - it should be falkon and not Falkon (notice the lowercase f).
So, additionally to what I mentioned above, and since you seem to be using Xfce, navigate to Settings Manager > Preferred Applications > Internet (tab) > under Web Browser insert falkon.

Thank you. Fixed the problem and all now OK.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.