Fakeroot binary missing

Hi I want to install “tracktion waveform pro” and found it n AUR. However I get an error when I follow the instructions found in the artivcle that @zoli62 linked here):

In command line I enter makepkg and this is what I get in turn:

~/Dokumente/tracktion-waveform >>> makepkg                                     
==> FEHLER: Cannot find the fakeroot binary.
==> FEHLER: Cannot find the strip binary required for object file stripping.

Unfortunately I’m not experienced enough to fix this by myself.

Regards

1 Like

Please see this:
https://wiki.manjaro.org/index.php?title=Arch_User_Repository

Particularly the part about needing base-devel package group before using the AUR.

(mode note - I moved your post as it was necroing an old thread, you are not actually converting a .deb package yourself, and this is a basic AUR question)

1 Like

Thank you.

Note to other noobs:
I could install the software of my choice, after installing binutils and fakeroot.

Enter pamac install base-devel into command line an choose what to be added by typing in respective number.
However, as you see in @cscs 's post below, it is recommended to just install the whole package.

Will have to check out if software works. If I don’t post on this anymore, it works.

No …
install all of base-devel if you intend to use the AUR.

(what you did here might technically work in this one instance … but next time you might require some other part, etc)

1 Like

Oi, too late!

I got the same error messages for both applications (obsidian and tracktion waveform pro).
I’ll install all of base-devel for future use hoping that the software will acutally work.

D: NOOB

The right command is:

sudo pacman -S --needed base-devel

This will install al missing packages of base-devel group

7 Likes

That solved it!
I can now install flowblade.
Thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.