Failure to boot from USB stick

I run Ubuntu 20.04 on my Dell Precision 5520 laptop and decided I’d like to mess around a bit with Manjaro. I downloaded the XFCE ISO and followed the instructions in a thread around here somewhere to use dd to copy it to a USB stick. I gpg verified the ISO (thanks, Phil) and that the SHA1 checksum of the bytes on the stick was identical to that of the downloaded ISO file.

I booted my laptop, holding down F12 (or was it F2?) to get into the UEFI setup and moved the USB stick to the front of the list, saved and continued. Upon reboot it came up in Ubuntu, despite the hard drive following the USB stick in the boot sequence. I saw no errors or suggestions it tried to boot from the stick. It just booted Ubuntu.

I know this must be a tiresome question for the experts, but I can’t explore Manjaro until I get past this point, and my forum searches yielded no obvious hints about what might have gone wrong (not much to search for since I saw no clues during boot).

Most motherboards have a boot menu for selecting a drive at startup - that’s generally preferred if you don’t intend to keep booting from the stick.

It’s the esc key on my laptop, f8 on my desktop - yeah, standards - but whatever key you find, it’s the best for temporary selections

Thanks for the response. That got me part of the way there, but I ran into a security violation. Turns out I needed to disable Secure Boot to get it to proceed. I was able to select the USB stick after that. I am now posting this note from within Manjaro running from my stick.