Failure in check php71 & php70

Hello there, im having this problem, i want to install either php71 or php70, im using

yay -S php71

but when building it says as the title

2019-06-11_12-47

and i dont know what to do

Hi,

it would be better to post the complete log as text, not a screenshot from a snippet no one can search or reformat.

First todo for you seems like reading about what the AUR is and maybe some comments about this package.
Second todo for me would be: ask the maintainer.

2 Likes

Is there a specific reason for not using the latest php version?

If you want to develop php there is absolutely no reason to use an older version.

If you want to develop with php you need to learn troubleshooting your system and supply textual logs rather than screenshots.

Copy the terminal output to the clipboard, paste it into a post - before you press Reply - mark the pasted text and format using the </> in the post toolbar.

2 Likes

so yeah...is there another way to upload the log?

so i uploaded the log to drive, its a text file

log

and we are using laravel 5.4 so i need a php version below 7.2

Maybe you should update your laravel version too... :grin:

my bad, i wrote 5.4 instead of 5.2 but the requirements are the same, this is on another laptop
image

here are the requirements
https://laravel.com/docs/5.2/installation

As requested before, please post text output as text (as in literally copy and paste it).


Given you're not going to be deploying on Manjaro I recommend you create a VM which matches your production environment. You can e.g. edit the files in Manjaro then push/sync them to the VM.

That way all the software and configuration is the same and you know that your development effort will work in the production environment without any hidden issues.

1 Like

cant do that cause it has more characters than the max allowed in a post/reply;
so i made a text file and uploaded it to drive, i previously shared the link but here you go

link to text file with output

You just posted a screenshot of php artisan --version . That's what I was talking about.

Posting a long log file should always be done via a "pastebin" site.

I'm not going to sign in to Google to retrieve a document.

Also please re-read my recommendation about using a VM which supports your particular use-case.

2 Likes

Cant upload to pastebin neither
the thing is in a previous version of manjaro i installed everything that i needed and it worked perfectly, but i no longer have access to that device, and now that im trying to install everything, im only missing php, and for the vm, can you share a way/video/resource on how to do it? just as plan b

ubuntu pastebin log output

There are other "pastebin" sites other than "pastebin.com". Although, if you're uploading a text file which is approaching a megabyte in size you might consider whether you're uploading something which is helpful.

Being able to read logs is key with any sort of development, but especially web development.

  1. Install Virtualbox
  2. Install the OS which matches your production environment
  3. Install the server software which matches your production environment
  4. Configure the server software
  5. Use the VM
  6. ???
  7. Profit

yeah, the only part that seemed of value to me was the one in the screenshot, since everything before that runs correctly, it only shows some deprecated warnings, and it crashes on the check function in the PKGBUILD;
thanks for the patience tho, i know this might be annoying

OK, so what I would do is take yay out of the equation.

cd $(mktemp -d)
git clone https://aur.archlinux.org/php71.git
cd php71
makepkg -sr

If the check() still fails then you can edit the PKGBUILD to add a progress flag, e.g.:

check() {
    cd ${srcdir}/${_pkgbase}-${pkgver}
echo "Running sendmail test"
    # Check if sendmail was configured correctly (FS#47600)
    ${srcdir}/build/sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q '/usr/bin/sendmail'

    export REPORT_EXIT_STATUS=1
    export NO_INTERACTION=1
    export SKIP_ONLINE_TESTS=1
    export SKIP_SLOW_TESTS=1
echo "Running run-tests.php"
    ${srcdir}/build/sapi/cli/php -n run-tests.php -n -P {tests,Zend}
}

This should at least tell you which test is failing.

1 Like

seems it is the sendmail,
2019-06-12_19-49

... and it's a screenshot again! :laughing:

its the same as the log previously shared, it just has an echo before the sendmail test...

and everything runs perfectly until that point, but somehow, i installed postfix, had the error, installed sendmail, during sendmail instalation deletec postfix because of conflicts, then tried installing php again, during php install deleted sendmail, because of conflicts again, once deleted, retried php install and it passed finally. Although i dont know how all that install and uninstall things got it working

It seems you're still missing the point.

You posted a screenshot of some text instead of copying and pasting the text that you took a screenshot of.

Not the whole log. Just the text you shared as a screenshot. You posted an image of some text.

You could have copied-and-pasted just the bit you took a screenshot of and posted that, e.g.:

Build complete.
Don't forget to run 'make test'.

==> Starting check()...
Running sendmail test
==> ERROR: A failure occurred in check().
    Aborting...

See? Posting text output as text.

However, given you're installing an old version of PHP with an old version of Laravel on a rolling-release distro to do development work for a different OS which is running different versions of everything compared to Manjaro I guess you don't worry too much about the little details...

k, ill try, whatever

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark