FAILED (unknown public key 105BD0E739499BDB)

I’m trying to install rvm through pikaur, but i receive the error in the title.
I have looked for a solution for a lot, and most of the people who seem to have solved issues with the same error message (different keyid and package) did so with
gpg --recv-key KEYID
It didnt work for me. The key was added (both with sudo and without it) but the error stood.
Some of them specified a keyserver with
gpg --keyserver SOME_URL --recv-key KEYID
and i tried a couple of those too, but nothing changed. Maybe i need to use a specific keyserver? I don’t even know which one i am using.
Is there anything else that might cause this problem?

You can see from the comments on the AUR page (AUR (en) - rvm) that other people have the same problem.

However, it works with pamac build rvm

You will be asked to import the keys.

unknown public key 105BD0E739499BDB

That is only a part (the last part) of the full key mentioned in the array:



I don’t know what that array does in the PKGBUILD, what is checked. :man_shrugging:

Perhaps try building it with pamac or yay instead of the tool you are using?
Or use makepkg to build it?

Or maybe you tried to import that partial key - which is not an existing key …

They are equal and represent the same key. One is the public key id, one is the fingerprint:

With pamac it installs but says that to use rvm i should do
source /var/tmp/pamac-build-valerio/rvm/src/rvm/scripts/rvm
However that command returns
bash: /var/tmp/pamac-build-valerio/rvm/src/rvm/scripts/rvm: No such file or directory

Never mind, i looked more in detail and found the file to source from, it was before the src folder (not present in my pc)