“Failed to start VirtualBox Linux kernel module…” Error on boot (continued)

This is a continuation of this post:

However, the first statement is incorrect.
The issue actually started when I installed virtualbox-bin, ever since then I started to get that error on boot when I install virtualbox from the official repos :frowning:

In my original post, I solved the issue by installing virtualbox-bin from the AUR, but now I want to use the Official version from the repo.

From the log, it seems like the vboxdrv service is running the incorrect file, maybe there’s a way I can “reset” it?

The weird thing is that virtualbox-bin works perfectly fine.

Thanks in advance.

UPDATE: I removed all the .service files relating to virtualbox, the error stopped showing up, but the kernel module won’t work (obviously)
I tried reinstalling the virtualbox and linux510/515/518-virtualbox-host-modules but that did not regenerate the kernel modules for some reason…
The only service file that is generated is the vboxweb.service file.
I tried:

❯ sudo modprobe vboxpci
modprobe: FATAL: Module vboxpci not found in directory /lib/modules/5.18.5-1-MANJARO

So I started looking around in the modules directory, and I found:

❯ ls /lib/modules/5.18.5-1-MANJARO/extramodules
nvidia-drm.ko.xz      nvidia-peermem.ko.xz  nvidia.ko.xz   vboxnetadp.ko.xz  version
nvidia-modeset.ko.xz  nvidia-uvm.ko.xz  vboxdrv.ko.xz  vboxnetflt.ko.xz  

a vboxdrv.ko.xz file… but I have no idea about what to do with it though :face_exhaling:

As said many times lately, AUR packages are unsupported.

Edit: I misread. Did you go over virtualbox manjaro wiki? You can also check archlinux wiki on it.


Loaded: loaded (/opt/VirtualBox/vboxdrv.sh; enabled; vendor preset: disabled)

doesn’t look like part of virtualbox in repo.

It isn’t, virtualbox from the repo is installed in /usr/lib/virtualbox
And that’s gone now, as I deleted those .service files.

I’m now looking for a way to regenerate the kernel modules and as I said, reinstalling doesn’t work.

either install the package for your kernel linuxXYY-virtualbox-host-modules or install the package virtualbox-host-dkms and the correct header package linuxXYY-headers.

When you mention USB - next thought is that your extension package does not match the vritualbox version.

That happens on stable branch because the extension package expects Arch package level of virtualbox which you only get on unstable branch.

I installed the linux510+515+518-virtualbox-host-modules and the issue was not solved. (I rebooted afterwards obviously)
And I still get this:

❯ sudo systemctl enable vboxdrv.service
Failed to enable unit: Unit file vboxdrv.service does not exist.

❯ sudo modprobe vboxpci                      
modprobe: FATAL: Module vboxpci not found in directory /lib/modules/5.18.5-1-MANJARO

❯ sudo modprobe vboxdrv

# No output

I’m going to try virtualbox-host-dkms and see if that happens. linux510+515+518-headers are already installed.

❯ cat /etc/group | grep vbox

The versions are matching and I’m added to all the vbox groups (I know vboxsf is for guest machines, but I still added myself anyway to see if that makes a difference - and it didn’t)

UPDATE: I installed the dkms package and got the exact results:

❯ sudo modprobe vboxdrv          
[sudo] password for myms:
# No output

❯ systemctl start vboxdrv.service
Failed to start vboxdrv.service: Unit vboxdrv.service not found.

❯ sudo modprobe vboxpci          
[sudo] password for myms: 
modprobe: FATAL: Module vboxpci not found in directory /lib/modules/5.18.5-1-MANJARO

Have you tried starting pamac clicking on installed searching for virtualbox and deleting everything related including in the aur then reinstalling virtualbox.

Good point, I’ll try that now and update.

To be uninstalled:


Damn…That didn’t…oh yea, I forgot to install it again :sweat_smile:
And the result:

❯ sudo systemctl enable vboxdrv.service
Failed to enable unit: Unit file vboxdrv.service does not exist.

The service should start on reboot.That’s all I could think of so I hope someone else can help you.Good luck.

1 Like

You don’t need to start this service. It should add the modules by default if you install them.

Do not confuse the guest with the host.

On host you install host modules - in guest only guest modules - and only if Manjaro guest.

I don’t have a vboxdrv.service running.

❯ systemctl status vboxdrv.service
Unit vboxdrv.service could not be found.

I don’t have a vboxpci kernel module loaded.

❯ lsmod | grep vbox
vboxnetflt             32768  0
vboxnetadp             28672  0
vboxdrv               540672  2 vboxnetadp,vboxnetflt

VirtualBox runs just fine.

❯ vboxmanage --version

Searching the Manjaro Wiki VirtualBox page for either returns zero results.

My guess is that residual files remained when you uninstalled virtualbox-bin from the AUR which led to the error messages on boot.

Are you having any actual problem with launching & running VirtualBox?


❯ lsmod | grep vbox
vboxnetflt             32768  0
vboxnetadp             28672  0
vboxdrv               544768  2 vboxnetadp,vboxnetflt

I get the exact results, so that means that my kernel modules work fine?

No, just that no USB devices are listed under the USB popup.

Do you mean that I should remove the virtualbox-guest-iso?
I thought that that was required by to host to install it on the guests.

Okay, that makes sense.

And I presume your USB devices are listed on the popup, right?
Not like this:

There is really no use for it - as it can be downloaded on demand from the GUI.

It is also only needed when the guest is when running a non Arch-based OS

Like when I run Kali? (this is pretty much all I use virtualbox for)

Regarding the USB problem, I’ve tried older versions of the extension pack, and kernels 510, 515, and 518 (They all ran the VMs surprisingly) but the USB popup remained as it is and the following remained the same too:

❯ vboxmanage list usbhost
Host USB Devices:


The last thing I will try is a brute force method, I’ll uninstall virtualbox, and then go through all my system files and delete everything to do with it, and then reinstall it and see if that makes any difference.

EDIT: I’ll try to run virtualbox from another user first.
EDIT 2: The second user account produces the exact output, starting the brute force method
EDIT 3: I forgot to mention that the problem is not with the extension pack, because shared folders work perfectly.

I wonder, have you added your user account and that other account you tried to the vboxusers group?

❯ cat /etc/group | grep vbox              

If I didn’t, I would’ve been told off by now

Welp, it was just an idea. I have no such issues with the virtualbox distributed by manjaro using kernel 5.15 and the extension pack downloaded from virtualbox. No idea why you’re having so many issues, good luck.

Did you even read the post?!

This issue is the remains of the virtualbox-bin package from the AUR, because I installed it, virtualbox (from the official repo) is now messed up.
Before I installed that package, virtualbox (from the official repo) worked perfectly fine.

So I removed every file/folder (except for the ones that returned a “Operation not permitted” error) that contains the word virtulabox or vbox and then reinstalled virtualbox and gained no success.

It looks like I’m going to have to stick with virtualbox-bin until I have time to reinstall Manjaro.
It doesn’t look like my investigation is going anywhere.