Failed to start simple display manager

My computer wouldn’t boot… says failed to start simple display manager


Would be useful to know if this started as random or after an update (that might actually go wrong) if you have a particular GPU … Can you access TTY log in from there and use startx ? Any errors there ? What kernel are you using …
Did you try, also from TTY to run another update with:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
And then reboot?

It happened randomly…I just swiched on my computer and I saw that. I tried the commands you suggested @bogdancovaciu

That looks like a DNS resolution error. Plea provide the output, a picture is fine, of:


as well as

ip a





This is the output @Mirdarthos

connect to the internet - neither your wireless nor your wired interface is connected
(you have no IP address)
once you have established a connection you can try again to update the mirror list and so on

power cycle your router - which likely provides your internet connection
or use your smart phone’s tethering to get a internet connection
be aware that an update through it will use a lot of mobile data volume

but this of course does not explain why sddm won’t start … maybe it will once you successfully run an update

Thank you this solution works for me @bogdancovaciu

You were right… It worked when I connected to the internet. Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.