Failed to start simple desktop display manager after creating 20-intel.conf

After trying to solve a screen tearing problem with creating a 20-Intel.conf file and editing it. After rebooting I got the “failed to start simple desktop display manager”

Tried to remove it by sudo rm /etc/X11/xorg.conf.d/20-intel.conf

Nothing worked. Any ideas ?

  Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=c07ba933-150a-4940-a99f-727cf4261180 rw quiet apparmor=1 
  security=apparmor resume=UUID=20cad62b-128d-46e4-8620-42ac3fe30f0d 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 20RW v: Lenovo ThinkBook 15-IML 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: LVA/LVAB v: NO DPK serial: <filter> UEFI: LENOVO 
  v: CJCN29WW date: 06/19/2020 
  ID-1: BAT1 charge: 44.9 Wh condition: 44.9/45.0 Wh (100%) 
  volts: 13.0/11.5 model: Celxpert L19C3PF1 type: Li-poly 
  serial: <filter> status: Full cycles: 22 
  RAM: total: 3.36 GiB used: 1.50 GiB (44.6%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: D6 L2 cache: 6144 KiB bogomips: 33615 
  Speed: 900 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 901 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat 
  arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
  clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl 
  dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d 
  fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb 
  ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca 
  mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 
  pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:9b41 
  Device-2: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-6:4 chip ID: 5986:2113 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: modesetting alternate: fbdev,intel,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 
  size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.7 
  direct render: Yes 
  Device-1: Intel vendor: Lenovo driver: snd_hda_intel v: kernel 
  alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:02c8 
  Sound Server: ALSA v: k5.7.19-2-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.048.03-NAPI modules: r8169 
  port: 3000 bus ID: 01:00.0 chip ID: 10ec:8168 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek vendor: Lenovo driver: N/A port: 2000 
  bus ID: 02:00.0 chip ID: 10ec:c82f 
  WAN IP: <filter> 
  Local Storage: total: 931.51 GiB used: 8.69 GiB (0.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0E scheme: GPT 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / raw size: 923.83 GiB size: 908.32 GiB (98.32%) 
  used: 8.69 GiB (1.0%) fs: ext4 dev: /dev/sda2 label: N/A 
  uuid: c07ba933-150a-4940-a99f-727cf4261180 
  ID-2: /boot/efi raw size: 300.0 MiB size: 299.4 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 label: N/A 
  uuid: F09A-9364 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.39 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/sda3 label: N/A 
  uuid: 20cad62b-128d-46e4-8620-42ac3fe30f0d 
  Message: No unmounted partitions found. 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-3:2 info: ASUSTek ROG STRIX IMPACT type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 0b05:1847 
  Device-2: 1-5:3 info: Shenzhen Goodix Goodix FingerPrint Device 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 
  speed: 480 Mb/s chip ID: 27c6:55a4 
  Device-3: 1-6:4 info: Acer SunplusIT Integrated Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 5986:2113 
  Device-4: 1-10:5 info: Realtek Bluetooth Radio type: Bluetooth 
  driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s chip ID: 0bda:c02f 
  serial: <filter> 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 
  speed: 10 Gb/s chip ID: 1d6b:0003 
  System Temperatures: cpu: 41.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 208 Uptime: 2h 37m Init: systemd v: 246 Compilers: 
  gcc: 10.2.0 Packages: pacman: 1175 lib: 313 flatpak: 0 Shell: Bash 
  v: 5.0.18 running in: konsole inxi: 3.1.05

More important is if there is anything in the log(s) about te failure.

for instance what is the output of journalctl -b and Xorg0.log

Unfortunately I reinstalled it all over again

If it is working now that’s what counts. But most of the time (like almost always) reinstalling is not necessary. But hey, if it did the trick it did the trick :slight_smile:

Believe it or not this is the 6th reinstalling :joy:.
The screen tearing thing is driving me crazy. Sometimes it’s tearing sometimes the video is not smooth.

Wow 6th install. Naah dont do that.

It seems I cannot find how much memory is allocated to you GPU.

what does the xorg0 log say about that.

grep -i --color memory /var/log/Xorg.0.log

Also how did you setup the 20-intel.conf?

this is what I added to the configuration.

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"

  Option "TearFree" "true"

tried grep -i --color memory /var/log/Xorg.0.log now and it didn’t give me any output from the terminal.

oke i would have aspect something like

❯ grep -i --color memory /var/log/Xorg.0.log
[    43.695] (--) NVIDIA(0): Memory: 2097152 kBytes
[    43.751] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[    43.822] (==) NVIDIA(0): Disabling shared memory pixmaps

try this in your conf.

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TripleBuffer" "true"
   Option      "TearFree"     "true"
   Option      "DRI"          "false"

I got no output at all

if anything goes sideways is it revertible ?

Normally this should work but if not a removal should do the trick.

could you first check if: xf86-video-intel is installed with

pacman -Qs xf86-video-intel

Or with pamac

If not install that first

this is the output.

local/xf86-video-intel 1:2.99.917+908+g7181c5a4-1 (xorg-drivers) Intel i810/i830/i915/945G/G965+ video drivers

Oke means that they are installed.

If not the config would not work at all so just needed to be sure.

just try it and see if it runs.
If not dont reinstall just give the outputs I ask for earlier. But I think it will work

can you please give me the exact line to create the configuration please. and the one to open it. really afraid to miss it up.

I added the configuration and rebooted. nothing happened I still have a noticeable screen tearing on videos and while scrolling.

Just create /etc/X11/xorg.conf.d/20-intel.conf with your favorite editor.

for instance

sudo vim /etc/X11/xorg.conf.d/20-intel.conf

copy the content and past it (in vim this goes with “shift”+“insert”)
save and close (in vim type “:x”)


already did but with these :
sudo mkdir -p /etc/X11/xorg.conf.d/
sudo nano /etc/X11/xorg.conf.d/20-intel.conf

but nothing changed I still have the screen tearing

This is only one option.

if this did not help edit the file and include this line

Option "AccelMethod" "uxa"

So it should look something like this:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod" "uxa"
   Option      "TripleBuffer" "true"
   Option      "TearFree"     "true"
   Option      "DRI"          "false"

There is a last option I know of, but only if this does not work.

btw forgot to ask but when does it tear?

I may did something stupid. I installed the linux-modesetting driver and now it’s stuck on the Lenovo sign.

While scrolling you can tell it’s not that smooth. And while watching a screen tearing test video on YouTube. I thought maybe it’s the browser so I downloaded the video. But there was no deference.

Why on earth would you do that :thinking:

chroot into you installation and please remove this driver.

I ask when it tears because for the browser I would also advice to enable hardware acceleration and disable smooth scrolling.