Failed to start Mullvad early boot network blocker

Hello everbody. Thanks for having me.
I am running Manjaro for a while now and I am very happy with it. Most problems so far I could handle thanks to the awesome documentation and great forum posts.
Now I got this.

I am using the AUR package


for a while now without problems.
Since the last update to version 2022.5-1 I get the following error in the boot log:

[FAILED] Failed to start Mullvad early boot network blocker. 

Things I looked up so far::

  1. startup service
systemctl status mullvad-early-boot-blocking.service


mullvad-daemon[241]: Error: Unable to get log directory
mullvad-daemon[241]: Caused by: Failed to set directory permissions on /var/log/mullvad-vpn
mullvad-daemon[241]: Caused by: Read-only file system (os error 30)

The service preset is disabled, although it is running while the system is running.
I tried to enable the service permanentely:

systemctl enable mullvad-early-boot-blocking.service

but the service preset is not changing.

  1. permissions
ls -al /var/log/


drwxr-xr-x   2 root root               4096  6. Nov 17:32 mullvad-vpn


ls -al /var/log/mullvad-vpn


drwxr-xr-x  2 root root  4096  6. Nov 17:32 .
drwxr-xr-x 11 root root  4096  6. Nov 17:32 ..
-rw-r--r--  1 root root 14214  6. Nov 17:47 daemon.log
-rw-r--r--  1 root root 18134  6. Nov 12:04 daemon.old.log
-rw-r--r--  1 root root  9586 24. Okt 11:15 old-install-daemon.log
-rw-r--r--  1 root root 11984  3. Nov 19:56 wireguard.log

I tried to give the root group writing permissions to the mullvad-vpn directory:

sudo chmod g=rwx /var/log/mullvad-vpn

But the change was undone after reboot.

I am running xfce and kernel 5.15.

Any ideas?

Yochanan is the maintainer of mulllvad so might be worth pinging him for help

Hello there. Maybe you can help me out on this?

Welcome to the forum! :wave:

I can’t reproduce the issue and I haven’t heard of anyone else experiencing it, either. Perhaps uninstall / reinstall mullvad-vpn-bin if you haven’t tried that already.

Please edit your first post with proper formatting.

It seems like it starts before the log directory is created/accessible. Maybe a timeout and/or (weird) configuration of the /var/log partition.
I couldn’t find the service file but maybe it depends on too much.

Yes, I tried that already; No change.

If that is the case, what could I do about it?

And please allow me this little OffTopic question: Why are my changes for writing permissions not permanent?

sudo chmod g=rwx /var/log/mullvad-vpn

What am I missing?

Thanks a lot!

Having the same issue as mentioned. Despite the error, I am able to start the mullvad app and connect to one of their VPN servers if I needed to do so.

Yes, I can run and use the program aswell without further problems once desktop is loaded.

Just found this thread after trying to help a user in a Telegram group with the same error. So something is odd with this package.

I think the block service starts too soon so that the var directory is not mounted yet.

Same “issue” with me, using an encrypted root partition and separate encrypted home partition.

However, it’s just a warning message. Unless you absolutely need the early boot blocker for your network connection for whatever reason, you can safely disable it. (You probably don’t need it.)

Just disable the service and you won’t get the warning messages anymore.

sudo systemctl disable mullvad-early-boot-blocking.service

I disabled it for now. Maybe are going to be some changes in the future.