"Failed to start Load Kernel Modules"

I recently downloaded Manjaro Linux and this is my first time using a linux OS. I was trying to install my graphics card drivers again because apparently Vivecraft NONVR didn’t like my current ones which I thought were correct, and kept telling me to install them again.

I followed a guide titled “How to install & configure nvidia driver on arch linux” because it was the first one that popped up for me. I can’t link it because the forums won’t let me.
I did step 1, then decided to reboot because Step 2 was telling me the syntax was incorrect.

After restarting the computer, it gives me “Failed to start Load Kernel Modules” and nothing else; I can’t even type.
I have no idea what to do and have tried searching this issue, but nothing is helping me.

All I can figure out how to do is hold SHIFT on booting the computer to go to a menu with “Manjaro Linux” and “Advanced options for Manjaro Linux” and going to the advanced options brings me to two choices which I assume are the kernels, but neither of them help and give the same error. And how am I supposed to do “sudo pacman -S linux 510” to reinstall the OS if I can’t even access a terminal in the first place?

Can anyone walk me through the process please?

Manjaro uses mhwd for easier installation of proprietary drivers and sort of: Configure Graphics Cards - Manjaro

1 Like

Okay, thanks. How do I actually fix the kernel load error and start
my computer?

Since I have no idea which guide and especially what you have done… I can’t say it exactly. But in general it is a good idea to boot the Manjaro Install Disk and chroot, like here: https://wiki.manjaro.org/index.php/GRUB/Restore_the_GRUB_Bootloader#Chroot_environment (but without installing grub)

There you can revert everything you have done and install it with mhwd.

howto dot lintel dot in/install-nvidia-linux-arch/

that’s the website i went to.
Also how am I supposed to chroot? There’s no terminal to enter any of the commands from the website you’ve given me.

I SHIFTed while rebooting into the “Advanced options for Manjaro linux” and edited the line that contains “vmlinuz” with “init=/bin/bash” at the end. It did something and it says:

bash: cannot set terminal process group (-1): Innapropriate ioctl for device
bash: no job control in this shell
[manjaro /]#

i can’t type at all either. why is it not working?

OK please read again:
it is a good idea to boot the Manjaro Install Disk and chroot

Btw… Since you are new here are some useful tutorials for beginner:


how do I “boot the manjaro install disk and chroot”? do I reinstall Manjaro the same way when I first installed it on my computer?
i do not know how to access a terminal from here, so any commands that i’m told to run will not help.

should I just install another OS altogether until the problem is fixed? Is there any way to completely delete/reset Manjaro so I can restart on a clean slate?

So you installed Manjaro with a downloaded ISO, right? This one boots a full desktop environment. There you have to open a terminal and chroot (change root directory on the terminal). Then you can act like being on the local installation on the terminal shell.

No chroot does not reinstall anything. It gives you access to the local installation in this case to solve your issue and undo things, you have done.

Depending on the Desktop Enviroment there must be an application on the startmenu called “Terminal” or “Konsole”.

Its up to you. Since you are a newbie on linux in general, I would advice to gain experience and maybe it is better to just reinstall and learn from this situation. By the way, Manjaro is not ArchLinux. There are differences on both Distros which could break your system as you can see now.

If you would have installed timeshift and sort of backup tools, sure, but its up to you which tool you want to use. A clean reinstall is the best way to reset the system to default, if you did almost nothing on the system.

:warning: Make a backup of your important files!

1 Like

Apparently you did not read even the excerpt of the tutorials you were told to read because:

So at this point:

  1. Do read the tutorials that have been given to you above because if Windows would be a car, Linux would be a racing motorbike, so you have to unlearn some skills you already know and have to relearn some new skills, so the tutorials you’ve been referred to will make your life easier!
    :blue_car: :motorcycle:
  2. Backup your data (if you already created any files; hopefully you messed it up straight away and have nothing to backup :grin: )
  3. Reinstall
  4. when you boot the Manjaro USB stick / DVD / … take “proprietary drivers” instead of “Open source” and you’ll get the nVidia drivers out of the box instead of having to follow the Lintel post ¹


Note 1: https://howto.lintel.in/install-nvidia-linux-arch/ goes 404, so we can’t verify what you did exactly…

1 Like

I did step 1, tried to do step 2 but it returned incorrect syntax, so then I rebooted and it broke. I had previously installed drivers from the Add/Remove Software application on Manjaro.

I’m just getting Windows and Ubuntu; Manjaro was clearly a mistake for a new Linux user like me. Spending 8 hours straight of your life just installing shit to get games running is not fun at all, and I was stumbling around in the dark all the time.

Once I’ve installed my new OSes, how do I delete Manjaro and everything on it to free up space on my SSD?

Sorry to see you go now, but you’ll be back as I migrated away from Ubuntu a few years ago because Canonical (The makers of Ubuntu) are taking Ubuntu in the wrong direction (I.E. Windows where the company decides what you can and cannot do)

You do that the other way around: you replace Manjaro’s partitions with Ubuntu’s while installing Ubuntu.


1 Like

Ah… that is now useful information… revert it in chroot:

manjaro-chroot -a
sudo pacman -Rcc nvidia
sudo rm /etc/pacman.d/hooks/nvidia.hook
sudo pacman -Syyu

Install it in manjaro with mhwd:

sudo mhwd --auto pci nonfree 0300

However… better stick with Ubuntu and learn how to use Linux in general. Ubuntu is really beginner friendly, because it has more predefined settings and is fixed release and therefore changes not really within its version. Manjaro is simple (what does not mean user friendly), but more something between “expert” and “beginner” level.

1 Like

Except this is Manjaro and you should have followed Manjaro’s own wiki and instructions.

Congratulations and bye bye.

I’m closing and unlisting this thread as it infringes several forum rules.

1 Like