Failed to start load kernel modules with nvidia-390xx

Hello Community,
Today I installed 21.0.5 gnome minimal lts and I installed nvidia 390xx driver (as my hardware doesn’t support any drivers latest than 390xx).
As I was saying after installation of driver I rebooted and got error:
Falied to start load kernel modules

And also, about a month before I installed the same gnome minimal . At that time after installing and reboot I didnt got an error.

Also for your information, I booted to live usb and tried pacman -Syyu & -Syyuu.

A month before i think the krrnel was 5.4.106 something and now it is 5.4.118 something. So changing my kernel would fix this problem.

Thanks for your kind support.


In the live system that will have no effect … or do you wanted to say you did that in the chroot of the installed system, from the live media?

Is that a statement or a question?
Partial updates are not supported, so downgrading the kernel will require also to go back to the old modules and probably more packages, leading to a very unstable system.

From the installed system TTY, please run:

sudo pacman-mirrors -f5 && sudo pacman -Syyu`
sudo mhwd -f -i pci video-nvidia-390xx
sudo mhwd-kernel -i linux510

then reboot your system with:

systemctl reboot

and once in grub, make sure you select the 5.10 kernel and see if the issue persists.

Thanks but i fixed it by just cleaning the package manager cache , I dont how it happened but it is working now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.