Failed to start Load Kernel modules GeForce GTX660 2GB


Yesterday I was prompted with more than 300 packages to update in my Manjaro installation.

I proceed to install and it gave me an error while compiling Qt. I tried to unistall Qt but the updated halted and I decided to re-start the computer.

After re-starting I got an error saying it can not load the kernel modules.

I tried with all the kernels I had in advanced options (going back until and I got the same error.

I when to the topics and I found a recommendation using a live usb. I install latest manjaro xfce 20 in the usb and booted the computer and I applied.

manjaro-chroot -a
pacman -Syu grub

And I got the same message.

I also tried to “continue” the installation and the answer was that there is nothing to update.

I have an nvidia GeForce GTX660 2GB and I do not know if that is the problem since I do not see listed in the message in red.

Thanking in advance for your support.

Why did you had to compile Qt ?

You wanted to uninstall Qt while the system was updating ?
Please don’t do random stuff in regard with update and uninstall if you want to keep your system functional!

From a chrooted system might still use outdated mirrors. Try with:
sudo pacman-mirrors -f5 && sudo pacman -Syyu


I have already tried that from the terminal and it didn’t work.

I hava access to the terminal through Ctrl + Alt + F2


try to reinstall the video driver from TTY:
sudo mhwd -f -i pci video-nvidia

and since you did not share on what kernel version you tried to boot and got the errors, i would suggest to also install another kernel:
sudo mhwd-kernel -i linux510
sudo mhwd-kernel -i linux54

and try to boot from one of them …

apa-pc login: rpirela
Last login: Tue Jan 19 21:51:03 on tty2
[rpirela@papa-pc 1$ sudo mhud -f -i pci video-nvidia
[sudol password for rpirela:

Installing video-nuidia…
Using default
Has lib32 support: true
Sourcing rvar/lib/mhud/db/pci/graphic_drivers/nvidia MHUDCONFIG
Processing classid: 0300
Sourcing Muar/lib/mhud/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases…
core is up to date
downloading extra.db…
warning: lib32-nuidia-utils-460.32.03-1 is up to date – skipping
Community is up to date
multilib is up to date
resolving dependencies…
looking for conflicting packages…
:: nuidia-utils and nu idia-430xx-utils are in conflict (nuidia-libg!). Renove
age conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nuidia-utils and nuidia-430xx-utils are in conflict
Error: pacman failed!
Error: script failed!
Crpirela@papa-pc 1$

Finally I sort out in the following way;

sudo pacman -R lib32-nvidia-utils
sudo pacman -R linux54-rt-nvidia-430xx linux414-nvidia-430xx linux419-nvidia-430xx
sudo pacman -S nvidia-utils
sudo pacman -S linux54-nvidia
sudo reboot
sudo mhwd -f -i pci video-nvidia
sudo reboot

Everything is working fine.

In another thread indicating that do not reboot just after removing the nvidia modules.

I hope this can help somebody.

Thanks for the support.

Best Regards,