Failed to start load kernel modules and /boot/efi

I was running on 5.4 and tried to get my bluetooth to work. So I tried all of the possible kernels up from 5.4 and installed all of them. Tested them and none worked, i was on kernel 5.9 (experimental) and then i uninstalled all of them except 5.4. I was running 5.9 when i uninstalled it. Then i restarted and after selecting manjaro in grub menu i got this error

Failed to start: Load Kernel Modules
Failed to mount /boot/efi
Dependency Failed for local File system

After that I followed this GRUB/Restore the GRUB Bootloader - Manjaro Linux

And I still have the same problem.

Any advice?

EDIT: now grub goes instantly into rescue mode aswell

error symbol grub calloc not found

Hi!

Since it is a problem with the kernel… not directly with grub (it just don’t find a kernel), try reinstalling the kernel.

sudo mhwd-kernel -r linux54
sudo mhwd-kernel -i linux54

Well I already messed up the grub and I will do a clean install to get the bluetooth to work.