Failed to start Live-System on Ryzen/RX550

amd
kde

#21

No real Idea… you could try to remove this from the boot line

nouveau.modeset=1 i915.modeset=1 radeon.modeset=1

and replace it with just amdgpu.modeset=1

but i dont think this would change something


#22

I installed Ubuntu (Gnome) 17.04 with Kernel 4.10 on this PC and its runs. So, I guess, it is a Manjaro-specific issue.
Before I tried the versions 17.0.3 and 17.0.4 from Manjaro before and had the same problems.

Maybe there is a problem in the live-system. Is there a parameter in boot-menu, which can help with correct loading the kernel-modules? Or is there a workaround for install without live-system?

Matthias


#23

How can I remove the entries from boot line? I found only a option to add parameter.

Matthias


#24

hm it shoule use Grub, so press “e” and you should be able to edit this.

But with

there is a point. Maybe the 4.9 Kernel dont supports that card, but only polaris 10/11. This would explain it conpletely


#25

Do I understand correct: Live-System from Manjaro use kernel 4.9, but install kernel 4.12? So the boot of Live-System is not possible, but an installation with kernel 4.12 of Manjaro should work?

Is it a good idea, to install with Manjaro architect? I don’t use this before.

Matthias


#26

I dont know for sure, but it is possible. Manjaro uses 4.9 by default, even on installed system. You can switch to other Kernels by yourself if you want to.

Yep architect would be an option, or force vesa by adding the boot options: nomodeset xdriver=vesa so you start the installation in low graphics mode (this will maybe not work on UEFI-only systems)


#27

I did this with ‘e’, but it leads to the same result.

And start with parameter
nomodeset xdriver=vesa
is the same.

It seems, the only option is installing with Manjaro architect.

Matthias


#28

I had some time to dig in a little deeper. Yep Polaris 12 needs at minimum linux 4.10, better 4.12.


#29

@matkoh: if you like, I can spin an ISO with linux413 for you. Only depends which profile you want. I can do it in a minimal edition, so you have stock applications and the ISO would be smaller.


#30

Thank you philm, but I use now Manjaro-Architect for installation. I choose Kernel 412, KDE and amdgpu as display driver.

It works! I write this post from the new Manjaro-installation.

For me, the problem is solved.

Matthias


#31

Linux 4.14 (next LTS) isnt to far away. Only Vega will still be a big problem


#32

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.