Failed to start LightDM after last pamac upgrade

After last pamac upgrade, my Manjaro does not boot on itself: after the grab menu, it stacks with an error [FAILED] Failed to start Ligth Display Manager. I can manually press ctrl + alt + F2, log in there and run startx, which would start my i3 environment that looks and behave absolutely as normal. How can I fix this Light Display Manager? I don’t even know where to find the error log, I tried to look at “journalctl - b”, but was not able to find anything relevant.

Hi @PG_LoLo, and welcome!

I suggest you try to re-sync. Open a terminal and run:

sudo pacman-mirrors -f5 --fasttrack

Followed by synchronising again:

pamac update --enable-downgrade

If this doesn’t work, report back with the output of

sudo journalctl -b --priority=3

Hope it helps!

try looking in /var/log/lightdm

sudo ls -hl /var/log/lightdm/

sudo because it’s only root readable

Also there is

cat /var/log/Xorg.0.log 

@Nachlese Thank you for pointing out the lightdm logs. I looked there, solved several problems (firstly installed lightdm-gtk-greeter, then installed Plymouth. As far as I understand, it is programs used by default, manjaro used something else on its places, that’s why they were not installed, but when I tried to reinstall lightdm I think configs were resetted). Now I am in the situation when it still does not work, but I do not see the reason in logs. Here they are:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=0 PID=1241
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0 has property CanMultiSession=no
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating greeter session
[+0.00s] DEBUG: Seat seat0: Creating display server of type x
[+0.00s] DEBUG: Using VT 7
[+0.00s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.00s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.00s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.01s] DEBUG: XServer 0: Launching X Server
[+0.01s] DEBUG: Launching process 1247: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.01s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.01s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.01s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.01s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.02s] DEBUG: Process 1247 exited with return value 1
[+0.02s] DEBUG: XServer 0: X server stopped
[+0.02s] DEBUG: Releasing VT 7
[+0.02s] DEBUG: XServer 0: Removing X server authority /run/lightdm/root/:0
[+0.02s] DEBUG: Seat seat0: Display server stopped
[+0.02s] DEBUG: Seat seat0: Stopping session
[+0.02s] DEBUG: Seat seat0: Session stopped
[+0.02s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+0.02s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
[+0.02s] DEBUG: Seat seat0: Stopping
[+0.02s] DEBUG: Seat seat0: Stopped
[+0.02s] DEBUG: Required seat has stopped
[+0.02s] DEBUG: Stopping display manager
[+0.02s] DEBUG: Display manager stopped
[+0.02s] DEBUG: Stopping daemon
[+0.02s] DEBUG: Exiting with return value 1

Here is my x-org log:

X.Org X Server
X Protocol Version 11, Revision 0
Current Operating System: Linux ROG 5.15.12-1-MANJARO #1 SMP PREEMPT Wed Dec 29 18:08:07 UTC 2021 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64 root=UUID=82e88458-0838-4d8e-84b0-b383fd2464c1 rw quiet apparmor=1 security=apparmor udev.log_priority=3 acpi_backlight=vendor
Current version of pixman: 0.40.0
	Before reporting problems, check
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan 23 21:18:41 2022
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Fatal server error:
(EE) no screens found(EE) 
Please consult the The X.Org Foundation support 
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) Server terminated with error (1). Closing log file.

I managed to solve the problem by installing optimus-manager (fun fact: several pamac upgrades ago I had the same problem with the system unable to boot, turned out some python compatibility broke for optimus manager and I deleted it).

Nevertheless, thank you very much for your help!