Failed to start light display manager, tried basic forum posts

Thanks for the reply and tip thinkingmachines.

Unfortunately with what I’ve done so far, ‘systemctl status lightdm’ returns ‘Unit lightdm.service could not be found.’ now.
I believe this is related to how I found lightdm to be masked and deleted the null pointer, but reinstalling with sudo pacman -S lightdm lightdm-slick-greeter doesn’t seem to restore it.

Good luck finding a more permanent solution for yourself. I might end up doing some cp* to backup and reinstall, been meaning to for a while : /.

I learned this hard way unfortunately. Todays update will break your PC and you will not be able to login because of lightdm service won’t start.

I have AMD CPU and Graphic Card.

Temporary solution:
CTRL+ALT+F2 then login with your user and run sudo lightdm - it should let you login to your desktop environment, but next time you reboot pc you will have same issue. I’m not really sure how to fix lightdm.service failure on boot - i reinstalled Manjaro today because of this and didn’t updated system until this gets fixed somehow. Hope i helped a bit. I’m curious what permanent solution to this would be. Good luck guys :slight_smile:

Edit: You can upgrade kernel to v5.10.2-2, it works well (i’m running it now) - It will not solve your issue but will also not break your system. Problem is most likely somewhere in one of those updates inside of “Update Software Tool”.

1 Like

@r4jk3 After running ‘sudo lightdm’ how do you then log in to the system? I was actually surprised it didn’t return a failure, but not sure what to do after that.

@Ghosty2012 after you execute that command you should see standard XFCE login screen. In case you cannot see it then you might be having some other problem with system. But this is what worked for me while i was troubleshooting this issue.

Which Kernel do you use? Had the same issue with 5.9.
Updated to 5.10 OK
5.4 OK

@r4jk3 Yeah, i think something in my troubleshooting steps broke lightdm for the easier fixes you and thinkingmachines suggested. If anyone can provide a suggestion for restoring lightdm as a service, prior to total reinstallation please? :slight_smile:

That’s the reason why I have 2 physical hard drives. On one drive is the system and on the other is the data, and in cases like this it becomes very handy because when reinstalling the system you don’t lose anything except your time :slight_smile: This can be achieved with single hard drive but then you have to create multiple partitions and need to be careful which one you are formatting. I will be tracking this topic, i’m also curious about the solution to this problem.

Yeah, I have the big old spinning metal for long term storage, just the day to day files on the SSD i’m chasing. I also remember having a seperate home folder patition vs the system partition from when I was distro hopping heaps, not sure how viable that is these days however.

@Ghosty2012 Take a look at THIS thread, seems they are troubleshooting same thing.

@Ghosty2012 can you please try what @The_Quantum_Alpha suggested and let us know if it works, so i can upgrade myself too :slight_smile:

I’d suggest waiting.
Performed “Enter sudo nano /etc/default/grub Find the line: GRUB_CMDLINE_LINUX_DEFAULT=” Add amdgpu.dc=0 Save, then run sudo update-grub" then rebooted. Now I have what I can only describe as corrupted 8-bit lines across the middle of the screen and the system is now unresponsive to control-alt-f3 to access TTY terminals.
Might be time for a reinstall for real this time.

1 Like

Hello there,
after a big update yesterday, I was also greeted with the error message upon reboot:

Failed to start light display manager

I updated the Kernel (sudo mhwd-kernel -i linux510), but it did not help with the issue.

The file /var/log/Xorg.0.log contains error messages:

[ 5.684] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 5.738] (EE) open /dev/dri/card0: No such file or directory
[ 5.738] (WW) Falling back to old probe method for modesetting
[ 5.738] (EE) open /dev/dri/card0: No such file or directory
[ 5.738] (EE) Screen 0 deleted because of no matching config section.
[ 5.738] (II) UnloadModule: “modesetting”
[ 5.738] (EE) Device(s) detected, but none match those in the config file.
[ 5.738] (EE)
Fatal server error:
[ 5.738] (EE) no screens found(EE)

After many reboots I noticed, that the startup actually sometimes succeeds. In those cases the xorg-logfile does not contain errors about a missing /dev/dri/card0

A possible cause is presented in the ArchWiki:

The amdgpu kernel module is supposed to load automatically on system boot.

It is possible it loads, but late, after the X server requires it.

The wiki then links to the fix: Kernel mode setting - ArchWiki

In my case I added amdgpu to MODULES in the file /etc/mkinitcpio.conf and regenerated the initramfs (sudo mkinitcpio -p linux510).

Happy new year!


Hi capsid, thanks for your suggestion. Similar issue was greeted and your way worked.

And thanks to everyone disscussed here.

1 Like

Hi @capsid,

I had exactly the same symptoms on my machine yesterday.
Some reboots goes well (can login normally), but most of them (over 95%) ends in failure.
I’m now in dilemma, should i update my system and try your solution (risk it all), or wait some kind of official fix in software center.

So can anyone else beside @zw0233 confirm this fix?

Thanks everyone for participation and problem solving.
Happy New Year!

I was too impatient to wait for the others, so i decided to upgrade my system on my own, and boom, i stumbled upon same problem again… Couldn’t login. So i applied @capsid’s solution and it worked! Thank you mister! Your solution worked like a charm, and I’m now able to login even after several restarts. @Ghosty2012 Please accept his post as a solution, because I’m sure it might help others to overcome this problem.

Well done @capsid! :clap: :beers:

1 Like

I’m having the same problem for my old nvidia laptop. Can someone give a tip how to solve this issue?

Thanks a lot for this post, after updating to 5.10 kernel I had no clue even from logs what could be the culprit and I would have never imagined that suddenly it was required to load amdgpu as a module.

Hey guys
A bit late here but updated my system and had the same issue… Idiot pamac tried to install 5.10 kernel AND linux-latest kernel (also 5.10) and I think linux-latest won the fight…

I removed both then just installed 5.10 ( and the issue is gone so I’m guessing they fixed it in a point update, no need to edit mkinitcpio, checked mine and the amdgpu entry is not in there

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.