Failed to start light display manager after update

This update completely halted my workflow in the worst time imaginable!

I get NO graphical UI (“failed to start light display manager”)

  • tried switching to lxdm without reboot (systemctl start lxdm)… nothing
  • tried switching to sddm without reboot … nothing

HOW CAN I ROLL IT (the update) BACK??

1 Like


  • Neither sddm, lightdm, or lxdm display;
  • lxdm keeps retrying and failing every few seconds;
  • I can actually get a SHELL after rebooting. (Ctrl+Alt+F2, etc…)
  • Since no graphic environment started, my PC motherboard’s splash screen was kept on, which led to the impression the boot process was taking forever.
  • Even for failed attempts, systemctl list-units shows the active dm as loaded active active;

I welcome any leads in how to UNDO the LATEST UPDATE.

I had the same problem and just fixed it. I used tty to install the open source driver and remove 450xx then once I got the kde gui I used the kde gui tool to install 440xx and remove the open source. Hope that helps.

I’m gonna wait for the next version of 450xx

1 Like

This makes sense, as startx errors with:

Fatal server error: (EE) no screens found(EE).

Could you please expand on your solution? What is the name of the open source driver? What commands were issued? Thanks in advance!

Please, please, please!!

HOW did you fix the problem?

I’m struggling without graphical UI for 7 hours straight, to no avail, with tons of work to do…

If I type “Install the open source driver” to a shell it won’t work, right? So one needs additional details!

@LinuxLoverForever Don’t be DenverCoder9:


I finally managed to recover the GUI with a workaround (I’ve tried and rolled back so many things in the last few hours, my recipe might be incomplete)!

As the problem seems to be with the nvidia 450xx thinghy, I switched from my previous linux57 kernel to the linux58, which can be associated to a 440xx nvidia package (named linux58-nvidia-440xx).

I issued a:

pacman -S linux58-nvidia-440xx

command, which brought the linux58 kernel as a dependency and rebooted. Eventually the graphical interface came up!!

So, now querying for linux58* in my system returns the following:

# pacman -Qs 'linux58*'
local/linux57 5.7.19-2
    The Linux57 kernel and modules
local/linux58 5.8.6-1
    The Linux58 kernel and modules
local/linux58-nvidia-440xx 440.100-12 (linux58-extramodules)
    NVIDIA drivers for linux.


@Yochanan that had me cracking up for 5 mins. (and probably the rest of the night) @cnaak I’m so sorry after I posted I went back to work. I only saw your thread because I was going to the update anouncement thread to give an update on my status and saw that this thread linked to it. I guess I should’ve written the mhwd commands and such. I know you solved it and sorry this wasn’t sooner but for future readers.

  1. Crt+Atl+F3 to get to ttyl
  2. login to your user account at the prompt
  3. run mhwd -i pci video-linux
  4. run mhwd -r pci video-nvidia-450x
  5. reboot
  6. it should boot into DE which for me is kde then I went to system settings GUI tool
  7. went to hardware configuration and installed video-nvidia-440xx and removed video-linux via right-clicking on the drivers.
    @cnaak That’s interesting that you found a kernel solution makes me wonder if 450xx would’ve worked if I was running the 5.4 LTS kernel because right now I’m on the 4.19 kernel. (10 minutes later…) OH CRAP NOT AGAIN!!!

btw I can totally relate to that image. Like when you find a stackoverflow question with your problem but either there’s no answer or there is but it doesn’t work. More recently I’ve been having the scenario where you find a github issue on your problem but the issue is still open.


Thank you very much, @LinuxLoverForever!

You did help me by pointing out things that made sense, that allowed me to try the kernel thing. Thank you!

I haven’t attempt your method, as to mark it as a solution (I don’t want to try it out by going “there” again with this nvidia-450xx problem that had annoyed me, frustrated and tired me so much today — and made me relate to this YouTube video: iYWzMvlj2RQ). I would have definitely tried it out before, though, while I still had the issue.

It puzzles me that part of the installs and removes (mhwd -i, mhwd -r, KDE Config etc.) aren’t done with pacman, even though they seem to operate in the packages… :thinking:

Once again, thank you so very much!

1 Like

I know I felt the same way at one point because before going down the route of installing the open source driver I was trying to install the 440xx driver via mhwd and couldn’t understand why it didn’t work. Looking back on it now it was probably because I still had 450xx installed. I wish mhwd would let you choose which driver to activate when you have multiple installed. I kept looking for a command like that when I was starring at the mhwd --help while in tty.

No worries about not marking it as the solution. I don’t blame you for not wanting to go through all that again especially on a work machine.

Also just wanted to give a word of advice. If wanting to do an update on a work machine I highly recommend waiting until the weekend to do so you time to troubleshoot. In my case it was a personal non-work machine it wasn’t critical even though it bugged me to solve it asap.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.