Failed to start GUI

Hello, after plugging all cables off of my PC, moving it around the room and plugging it back again my PC fails to start.

Namely when I run the PC, it boots up, shows up smth about my NvmE memory’s files and blocks, then the screen goes black for about 1 sec, then I see the same screen again and after a few seconds the cursor stops flickering and nothing happens anymore (I have waited a few minutes at this point and nothing changed).

I can use Ctrl+Alt+F2 to open the terminal and log in. When I run the startx command, I see a bunch of lines, the last three (which follow after the initial Markers description) are

(==) Log file: "/var/log/Xorg.1.log", Time: Tue Sep 27 22:12:32 2022
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

At this point the terminal freezes (the cursor stops flickering) and I need to open a new one with Ctrl+Alt+F3.

Also if I try to run say kinfocenter or plasmashell i get:

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

(Translation here, as this part is in my local language) Aborted unsuccessfully (SIGABRT) (core dumped (image of memory saved))

Could you please help me get back to the GUI? I can use terminal to some extent, but please be rather verbose with instructions. I also really do not know what should I do, the commands whose output I showed seemed just something possibly related from other answers to seemingly similar problems.

Also the terminal outputs may contain minor typos since I wrote them by hand. I tried to check, but still, consider yourself warned.

try disconnecting and connecting again the cables…
if it doesnt help, take a picture of the startx output…
and do you have a manjaro usb? the best way to troubleshoot would be from there, using chroot.

startplasma-x11 and read log file in this message
And you can also read journald journalctl -b0 -p err --no-pager

startplasma-x11 returns

$DISPLAY is not set or cannot connect to the X server.

This is admiteddly suspicious, can I somehow find the correct value? (on my NTB it is “:0”)

Also here is a pastebin of the journalctl command.

Reconnecting the cables did not help.
Here is the picture of all the info I get from startx

Also I tried startx > some_file and here is the output.

there is no error from the startx …
post output from:
mhwd -l && mhwd -li
find /etc/X11/ -name "*.conf"

concatenated output of the mhwd commands is here
output of find is


so why do you have installed video-nvidia instead of the hybrid drivers?
post output from:
inxi -G
post picture of it, no need to use pastebin

And to answer the question: I have nvidia drivers since I wanted to do some machine learning through tensorflow with my RTX 3060.

ok, so try to uninstall the drivers:
sudo mhwd -r pci video-linux
sudo mhwd -r pci video-nvidia
install the hybrid one:
sudo mhwd -a pci nonfree 0300
systemctl reboot
and see if it helped

you can do that also with the hybrid one, by installing optimus and switching between intel/hybrid/nvidia …

Reinstalling the drivers solved the issue.

Just for the record, I had to manually uninstall conky-manager, than conky to be able to uninstall the nvidia driver.

Thank you very kindly for your help.

if you want to use only nvidia, you can use it by running this command:

also you can install optimus-manager, open this file:
kate /etc/sddm.conf and simply put a # before the line starting with DisplayCommandand the one starting with DisplayStopCommand:
you may not have these display lines there in the conf;
now install optimus:
pamac install optimus-manager optimus-manager-plasma
and you can switch between gpus from the optimus tray

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.