Failed to prepare transaction during update

Hello I didnot update for like a month and just today thought of updating, it shows error. Have two kernel 515 and 516.

Do you want to continue anyway? [y/N] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (515.48.07-2) breaks dependency 'nvidia-utils=510.60.02' required by linux516-nvidia

removed the 515 and tried installing any 518 519 but shows the same error

You need to remove kernel 5.16 and the relating nvidia utils first.

1 Like

hello i tried to remove 516 it says cannot remove the current kernel, its the only kernel i have

So based on that information, what do you think you should do then?

5.16 is EOL, while 5.15 is LTS and still maintained, so you should have kept the latter instead.
Now you’ll need to do a big roundabout in order to be able to update:

  • Replace non-free drivers with free drivers
  • Install a supported kernel
  • Reboot to a supported kernel
  • Remove 5.16 kernel
  • Replace free drivers with non-free drivers
  • Reboot

I hope you’ll manage to fix the issue!

To avoid similar problems in the future, it is recommended to keep at least two kernels.
I usually keep the last LTS kernel and the most recent.

Best Erim

1 Like

@zbe well if i knew what to do, i would not be here :slight_smile:

@maycne.sonahoz thank you, do i need a specific version or something i don’t know much about linux

@Erim thank you i will keep that in mind

Any supported version, preferably recent. Just don’t forget to manage them.


@maycne.sonahoz hello i somehow installed 517 and 518 :sweat_smile: by using sudo pacman -S

there is no 5.17 kernel available…
uninstall this:
sudo pacman -R linux516-nvidia
post output from:
mhwd-kernel -li

1 Like

@brahma hello

 mhwd-kernel -li                                                                  
Currently running: 5.16.18-1-MANJARO (linux516)
The following kernels are installed in your system:
   * linux516
   * linux517
   * linux518

so reboot and select the 5.18 in the grub menu, and uninstall these:
sudo pacman -R linux516 linux517
and install the 515:
sudo mhwd-kernel -i linux515

1 Like

@brahma hello i think i am done here right? Now i am able to update

Then pacman -Syyu on console.
Have you updated the mirror list of pacman ?

1 Like

@Keruskerfuerst yes thank you i updated the mirror also

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.