Failed to prepare transaction ( could not satisfy dependencies )

Hello people,

System:    Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=e367bb09-f515-46b1-bfc0-e8a98949314e rw 
           quiet resume=/dev/nvme0n1p1 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20NBCTO1WW v: ThinkPad E590 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: LENOVO model: 20NBCTO1WW v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO v: R0YET25W (1.08 ) 
           date: 11/28/2018 
Battery:   ID-1: BAT0 charge: 35.7 Wh condition: 36.0/45.0 Wh (80%) volts: 12.3/11.1 model: LGC 01AV445 
           type: Li-poly serial: <filter> status: Unknown cycles: 417 
           Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming Mouse serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
Memory:    RAM: total: 15.36 GiB used: 2.68 GiB (17.4%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 8E (142) stepping: B (11) microcode: D6 L2 cache: 8192 KiB bogomips: 32012 
           Speed: 600 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 600 2: 600 3: 600 4: 600 5: 600 6: 601 
           7: 600 8: 600 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx 
           avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 
           dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp 
           hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca mce 
           md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb 
           pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse 
           sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx 
           vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:3ea0 
           Device-2: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X] vendor: Lenovo driver: amdgpu 
           v: kernel bus ID: 03:00.0 chip ID: 1002:699f 
           Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo bus ID: 1-6:5 chip ID: 13d3:56a6 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu,intel FAILED: ati 
           unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: HDMI1 res: 1920x1080 dpi: 90 size: 540x300mm (21.3x11.8") diag: 618mm (24.3") 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.1.7 direct render: Yes 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:9dc8 
           Sound Server: ALSA v: k5.8.6-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 
           v: kernel port: 2000 bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 2000 bus ID: 05:00.0 
           chip ID: 8086:2526 
           IF: wlp5s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           Device-3: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb bus ID: 1-5:4 
           chip ID: 8087:0025 
           WAN IP: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 149.14 GiB (62.5%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: 0106ADLA scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / raw size: 221.27 GiB size: 216.80 GiB (97.98%) used: 149.14 GiB (68.8%) fs: ext4 
           dev: /dev/nvme0n1p2 label: N/A uuid: e367bb09-f515-46b1-bfc0-e8a98949314e 
           ID-2: /boot/efi raw size: 300.0 MiB size: 299.4 MiB (99.80%) used: 280 KiB (0.1%) fs: vfat 
           dev: /dev/nvme0n1p1 label: N/A uuid: 57DF-1A6C 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 16.90 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
           label: N/A uuid: 6e1ce6a6-f4dd-4438-8183-bc1ad18ebe36 
Unmounted: Message: No unmounted partitions found. 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-1:2 info: Logitech USB Receiver type: Keyboard,Mouse,HID 
           driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 046d:c53f 
           Device-2: 1-3:3 info: China Resource Semico USB Keyboard type: Keyboard,Mouse 
           driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s chip ID: 1a2c:4c5e 
           Device-3: 1-5:4 info: Intel Wireless-AC 9260 Bluetooth Adapter type: Bluetooth driver: btusb 
           interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0025 
           Device-4: 1-6:5 info: IMC Networks Integrated Camera type: Video driver: uvcvideo interfaces: 2 
           rev: 2.0 speed: 480 Mb/s chip ID: 13d3:56a6 serial: <filter> 
           Device-5: 1-8:6 info: Synaptics Metallica MOH Touch Fingerprint Reader type: <vendor specific> 
           driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 06cb:00a2 serial: <filter> 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 46.0 C mobo: 0.0 C gpu: amdgpu temp: 46 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 265 Uptime: 1h 01m Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: apt: 0 
           pacman: 1373 lib: 394 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

I have been trying to run a system update but failed because of the libutil-linux package.
Here is my sudo pacman -Syu Output

 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace libutil-linux with core/util-linux-libs? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libutil-linux breaks dependency 'libutil-linux>=2.16' required by skypeforlinux

I tried removing libutil-linux first and then do the update but failed because removing it breaks some dependencies
Thanks in advance!

“pacman -Rdd libutil-linux” will remove it with no dependencies touched, do the update and reinstall if needed.

Remove this package first. If you need it you can reinstall after updating.


:no_entry: Don’t use pacman -Rdd if not really needed (strongly NOT RECOMMENDED if you’re unsure of what you’re doing), this could produce broken systems …

If i removed skypeforlinux and then updated the system installed the package again, wouldnt that create the same conflict later?

Normally not, but it depends how you originally installed the package (repos / AUR). It’s common pratice to remove packages hindering you to update and to reinstall them afterwards if needed.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.