Failed to login on my session


Sin yesterday I am unable to be connected to my session. My psw is written as incorrect (of course I type it well). But worst I tried to launch a TTY screen, and also it is the same issue : my login and psw are not recongnized.

I hope to avoid a new install, so I count on you please.


PS : I saw that solution HERE but no success.

Can you login on console as user or root ?

Just saw or implemented also?

Not at all :kissing_closed_eyes:

I do ctrl + alt + f2 I access to tty2

I type my login = yvance
Then my pwd = xxxxxxxx

Result : Login incorrect

Of course I tried it as chroot … but I did not any success

Can you login as root ?

No I can’t

Then you may delete the entries of your user and root account in /etc/shadow.

Sorry but I am not sure which entries I might delete ?

These 2 ? :


Why? What happened since you were able to? What did you do?

Well, what did you do? What was the result?

Your what? Please use full words, not invented abbreviations. You’re not using a T9 keyboard and there is no character or word limit here.

Please see:

NO! Anyway, how is he going to do that if he can’t login as root?

None of them. NEVER edit that file manually. See Users and groups - ArchWiki

Restore your backup. You do make backups, right? :wink:

I did find a solution to use “timeshift”. I used an image saved from mid january, I restored it, made an update of the system, then it works again.

Thanks for your support.

I’ve closed and unlisted this because you have wasted everyone’s time who have attempted to help when you could have just restored your backup to begin with.

Please read the forum rules and tutorials I’ve linked above before posting next time.

Also there is bad advice that no one should follow here.