Failed To Load Kernel Modules error after update

Hi everyone!

my first post here and I apologise if I’m posting a duplicate but I am confused how to fix it.

I’m still fairly new to Linux and after the last big update using the stable branch of Bspwm with kernel 5.4.89 i think ( I originally installed awesome wm community edition - then installed Bspwm that ive been using) on reboot i had several lines of the error [Failed] Failed to load kernel modules

I’ve done alot of searching and reading posts etc
I tried to manjaro-chroot -a (for the first time) and installed a new kernel 5.10 and then the Nvidia drivers but that didnt help.

I’d prefer to fix the original 5.4 kernel to keep with the stable branch.

I have the manjaro grub screen and luckily I still have an i3 manjaro that I can boot into but I’d like to go back to my main system.

Now I’m confused and at a loss and would be grateful if someone could help to fix it as I’d like to use this as an opportunity to learn instead of just reinstalling.


While I don’t really have an idea what can cause it, I’m just going to leave a comment and a suggestion.

I don’t know if you know this, but Kernel 5.10 is in the stable branch now. I’m running it myself. 5.10 is also set to become the next LTS (Long Term Support) version. So there’s no real reason not to use it.

When you startup your computer, just after the BIOS logo, press the ESC a couple of times. You should receive the GRUB boot menu. Use keys and navigate to the Advanced options menu. There you can check if any specific kernel works correctly.

Also, if possible, please post the output of

inxi -Fazy

as well as

mhwd -l


mhwd -li

Kind regards.

Thanks, if you mean the Manjaro grub menu which shows all the installs on my SSD? then I’ve tried all kernels in the Advanced menu 4.19, 5.4 and 5.10 and none work, including the fallbacks

I’ll try to get the output I assume I do this by dropping to tty on the failed install?

here is the output requested - this is from my i3 install that works as I don’t know how to save it from the failed install as I said I’m new to linux terminal

inxi -Fazy
  Kernel: 5.4.89-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=7e3abef2-5a20-4b40-a128-1c56c91ff9cd rw quiet 
  Desktop: i3 4.19 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: Z97-D3H v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: Z97-D3H-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F7 date: 06/17/2014 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  Info: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 
  L2 cache: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 64024 
  Speed: 1590 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 1590 2: 1510 
  3: 1586 4: 1564 5: 1569 6: 1559 7: 1513 8: 1594 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor:. driver: nvidia 
  v: 460.32.03 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1401 
  Display: x11 server: X Org 1.20.10 driver: loaded: nvidia display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 3840x1200 s-dpi: 93 s-size: 1049x331mm (41.3x13.0") 
  s-diag: 1100mm (43.3") 
  Monitor-1: DVI-I-1 res: 1920x1200 hz: 60 dpi: 94 
  size: 519x324mm (20.4x12.8") diag: 612mm (24.1") 
  Monitor-2: HDMI-0 res: 1920x1080 hz: 50 dpi: 70 size: 698x392mm (27.5x15.4") 
  diag: 801mm (31.5") 
  OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
  direct render: Yes 
  Device-1: Intel 9 Series Family HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8ca0 
  Device-2: NVIDIA GM206 High Definition Audio vendor:
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fba 
  Sound Server: ALSA v: k5.4.89-1-MANJARO 
  Device-1: Intel Ethernet I217-V vendor: Gigabyte driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:19.0 chip ID: 8086:153b 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 5.29 TiB used: 37.47 GiB (0.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDH3 500G 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 00RL 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZEX-00BN5A0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 1A01 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD10EZEX-00BN5A0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 1A01 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 850 EVO 250GB 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 1B6Q 
  ID-5: /dev/sde maj-min: 8:64 vendor: Western Digital model: WD30EZRZ-00Z5HB0 
  size: 2.73 TiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 0A80 
  ID-6: /dev/sdj maj-min: 8:144 type: USB vendor: SanDisk model: USB 3.2Gen1 
  size: 57.3 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1.00 
  ID-1: / raw size: 88.37 GiB size: 86.48 GiB (97.86%) used: 32.06 GiB (37.1%) 
  fs: ext4 dev: /dev/sda8 maj-min: 8:8 
  ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) 
  used: 1.3 MiB (0.3%) fs: vfat dev: /dev/sda7 maj-min: 8:7 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 14.65 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 43 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 234 Uptime: 3m wakeups: 2 Memory: 15.54 GiB 
  used: 1.73 GiB (11.1%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1225 lib: 294 Shell: Bash v: 5.1.0 running in: terminator 
  inxi: 3.2.02
mhwd -l
> 0000:01:00.0 (0300:10de:1401) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2020.11.30               false            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI
 mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2020.11.30               false            PCI

Warning: No installed USB configs!