Failed to load kernel modules after 2020-08-26 testing update

I have an error after change from stable to testing and run this update.

Fail to load kernel modules
  Kernel: 5.8.1-3-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=ac99531c-fb80-4e21-943e-dffb8acccce4 rw quiet acpi_osi=linux 
  acpi_backlight=vendor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DD_FX505DD v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FX505DD v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FX505DD.310 date: 12/24/2019 
  ID-1: BAT0 charge: 25.1 Wh condition: 43.4/48.2 Wh (90%) volts: 11.4/11.9 
  model: FX50442 type: Li-ion serial: N/A status: Discharging 
  Topology: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 18 (24) 
  stepping: 1 microcode: 8108102 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 33548 
  Speed: 1300 MHz max: 1400 MHz boost: disabled Core speeds (MHz): 1: 1282 
  2: 1327 3: 1222 4: 1239 5: 1223 6: 1323 7: 1223 8: 1223 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP107M [GeForce GTX 1050 3 GB Max-Q] driver: N/A 
  alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 chip ID: 10de:1c91 
  Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 05:00.0 chip ID: 1002:15d8 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 3-1:2 chip ID: 13d3:56a2 serial: <filter> 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: AMD RAVEN (DRM 3.38.0 5.8.1-3-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.5 direct render: Yes 
  Device-1: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.8.1-3-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI modules: r8169 port: e000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: AzureWave driver: rtl8821ce v: N/A modules: 8821ce port: d000 
  bus ID: 04:00.0 chip ID: 10ec:c821 
  IF: wlp4s0 state: down mac: <filter> 
  Local Storage: total: 1.14 TiB used: 280.77 GiB (24.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPNUW-256G-1002 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 serial: <filter> rev: 20110000 scheme: GPT 
  ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-00Z10T0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 1A01 scheme: MBR 
  ID-1: / raw size: 49.26 GiB size: 48.24 GiB (97.92%) used: 14.95 GiB (31.0%) 
  fs: ext4 dev: /dev/nvme0n1p5 
  ID-2: /home raw size: 62.50 GiB size: 61.27 GiB (98.03%) 
  used: 1.23 GiB (2.0%) fs: ext4 dev: /dev/nvme0n1p6 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.49 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p2 
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: amdgpu temp: 40 C 
  Fan Speeds (RPM): cpu: 2300 
  Processes: 238 Uptime: 29m Memory: 15.14 GiB used: 3.48 GiB (23.0%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: pacman: 1106 lib: 298 
  Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.05 

Which module failed to start?

journalctl -b -u systemd-modules-load.service --no-hostname --no-pager

I can’t run that, I’m not able to change to a tty, the system stop booting up at that point


Looks like the nvidia-450xx it’s the problem. I had nvidia-440xx, in order to uninstall it I had to remove linux-latest-nvidia-440xx, all went fine, then install nvidia-450xx, all went fine again, reboot and all went wrong, still making test…

How did you get your inxi form the first post?

But if you can’t switch to a tty, you need to boot a Live version form a thumb drive. Chroot and then fix your nvidia problem. You probably did not installed the kernel modules for nvidia-450. So the modules can’t load. But this is just a guess.

The inxii info it’s before the issue, i had loaded a timeshift backup.
During the instalation of nvidia 450xx the modules are installed for linux57/58 without problems

Maybe it is something else. But impossible to say without checking the journal form an unsuccessful boot.

First thing first, thanks for your fast answers.
I know, that’s why I’m still making test, the problem occurs also in the stable branch, so right now i just change to testing and update the system successfully, now i’m gonna try to install again the 450xx, if the system break again, then live mode, chrroot and check the journald…
Stay tuned for my next episode!!! xdddd

OK, just let us know. Normally the 450xx modules should work as most of the users are using this new driver. I’ll push another RC out when we do another stable branch update to test before the final install medias get created.

After install nvidia-450xx still having the same error, but this time I was able to change to a tty, run the command proposed by @xabbu

The output show no entries, so i run

journalctl -xe

And the output show this among other things

system-modules-load[1320]: Error running install command ´/bin/false/ ´ for module nvidia : retcode 1
system-modules-load[1320]: Failed to insert ´nvidia´ : invalid argument
system-modules-load[1320]: Error running command ´/bin/false´ for module nvidia : retcode 1
system-modules-load[1320]: Failed to insert module ´nvidia_drm´ : invalid argument

systemd-modules-load.service : Failed with result ´ exit-code´
Failed to start Load kernel Modules

I uninstall nvidia-450xx drivers and I was able to boot up the system, then install nvidia-440 with the same result as nvidia-450 and the same errors in journal.
All installations by tty with

sudo mhwd -i/-r pci driver