Failed to load driver nouveau after uninstalling it

I have uninstalled Nouveau driver and installed Nvidia proprietary driver instead.

When i run DRI_PRIME=0 glxinfo | grep OpenGL it shows the intel integrated video card,
and if i run DRI_PRIME=1 glxinfo | grep OpenGL it shows an error message
libGL error: failed to create dri screen libGL error: failed to load driver: nouveau .

However if i run prime-run glxinfo | grep OpenGL instead, then it shows nvidia gpu correctly.

does anyone know how to fix DRI_PRIME=1?

This is the command when you have the open nouveau drivers.
With the proprietary drivers you use prime-run

That is, of course assuming you properly managed your drivers through mhwd (or GUI manjaro-settings-manager) and are using a PRIME profile like video-hybrid-intel-nvidia-prime.

This all means things are working as expected.

Please familiarize yourself with the wiki(s):
Configure Graphics Cards - Manjaro
PRIME - ArchWiki

Thanks! So DRI_PRIME only work for open-source drivers, and for proprietary drivers i will have to use prime-run. I thought that I didn’t uninstalled the nouveau completely.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.