Failed to initialize the NVIDIA kernel module

I rebooted my system and was met with the error message:
failed to start light display manager

Tried following the guide given at [1]. However, no luck.

in /var/log/Xorg.0.log i see the error message:

(EE) NVIDIA: Failed to initialize the NVIDIA kernel module

Before the reboot i did update the kernel, from 5.8 to 5.9. That might be relevant.

Any idea what i can do to fix this? Help is appreciated!

[1] As a new forum user I could not include links. The page title for the link is: “Manjaro doesn’t boot, boots to a black screen, or stops at a message”

  1. How you installed kernel? With mhwd (good) or with pamac/pacman (wrong, in that case you also need install drivers manually)?
  2. What card and drivers you have?
1 Like
  1. I used the Manjaro settings manager, and used the kernel option in there. I’ve never had any issues before, as I have updated kernel several times.
  2. sudo lshw -C video: “GTX 1060 6GB” and sudo lspci -v | less shows kernel modules: nouveau. however, there is no “Kernel driver in use:” entry for the video card. Does that mean missing driver?

sudo pacman -Sy $(pacman -Qq | grep linux58 | sed -e ‘s/linux58/linux59/’)

… should fix missing extramodules …

1 Like

Thanks! Tried it, and got the result:
error: target not found: linux59-nvidia-440xx

So, nvidia for 5.9 was not automatically installed after i installed new kernel?!


sudo pacman-mirrors -f3
sudo pacman -Syyu

… gives “there is nothing to do”

Should i manually try to install linux59-nvidia-440xx? If yes, how?

Kernel 5.9 doesn’t support that driver series. Most likely we will drop older Nvidia drivers at some point. check with mhwd if other driver series are supported on your hardware.

1 Like

mhwd shows video-nvidia-455xx version 2020.10.04 as the latest. Next to this I see video-linux, video-modesetting and video-vesa. They’re all old.

So, due to the age of my graphics card I can’t run 5.9?

How can I start Manjaro with 5.8 again? I don’t see any option to select kernel, in GRUB, when booting my system. I have no “advanced option”, something I believe was there earlier. Note that I did not uninstall the 5.8 kernel.

What is your graphics card? Usually if manjaro settings manager lists a driver its compatible with your card but you can check on nvidia website the latest driver compatible with your card

My card is GTX 1060 6GB. It’s from 2016, so I find it a bit strange it’s too old. As well, if the Manjaro team decides to drop supporting this card soon it also seems early to me.

Is there no easy way to restart my system with my previous kernel? Does anyone know how I can enable the “Advanced Options for Manjaro Linux” in GRUB?

On most desktops its holding shift while booting that enables grub menu as its hidden by default. Pretty sure your card is supported by 455 drivers, id use manjaro settings manager and auto install latest non free drivers

1 Like

Thanks a lot, @sawdoctor. I was unaware of the option to hold shift down. I’m now finally back on my main system, running the 5.8 kernel.

Ah, I see what you’re saying. I’m on 440xx, not 455xx. My bad. Didn’t actually realise that I was lagging behind. I will try installing 455xx. Thanks again.

With your help, @sawdoctor, I’m now running kernel 5.9.3 on my system. Thanks a lot!


After my system didn’t restart, I was able to hold shift down on reboot and select the previous 5.8 kernel in GRUB. Then, in Manjaro Settings Manager I uninstalled video-nvidia-440xx and installed video-nvidia-455xx. Rebooted my system, selected 5.9 kernel in GRUB, and all was good.

1 Like

Glad you got it all sorted :+1:

1 Like

same issue here, though I have found I am unable to reinstall nvidia drivers.

Additionally, I have two GPUs, a 1070 and a 2070S, the latter being shunted to the win10 VM

I was able to boot to 5.7.19-2, when I got to uninstall the 440xx I get:

Removing video-nvidia-440xx…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-440xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux58-nvidia-440xx breaks dependency ‘linux58-nvidia-440xx’ required by linux-latest-nvidia-440xx
Error: pacman failed!
Error: script failed!

if I go to just install 455xx I get:

Waiting for user input…
Error: config ‘video-nvidia-455xx’ conflicts with config(s): video-nvidia-440xx
Done …

Have you uninstalled the 440 drivers? You need to uninstall them before you install the 455 ones

It’s throwing the first error when I go to uninstall

edit: as a solution I am trying to

sudo pacman -R linux-latest-nvidia-440xx

and the uninstall and reinstall, will report back…

SUCCESS! double solved in this case


Glad you got it sorted, I’m surprised linux-latest put on 440/linux 58 but someone cleverer than me will probably know

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.