Failed to execute init (error -2) kernel panic after latest update

You should have that yourself in /var/cac/pacman/pkg/
Install with pacman -U

Copy the dotfiles from your /home so you get the same configuration? Save package list and install that list on new installation?

Nope! According to the output of ls in the file I linked to above, I’ve only got the following files that contain the string openrc in /var/cache/pacman/pkg:

autofs-openrc-20170401-1-any.pkg.tar.xz
bluez-openrc-20170401-1-any.pkg.tar.xz
cups-openrc-20170401-1-any.pkg.tar.xz
openrc-0.27.2-1-x86_64.pkg.tar.xz
openrc-sysvinit-2.88-10-x86_64.pkg.tar.xz

…so I don’t have openrc v0.26 :confused:

…I guess. I would still really like to use openrc though (to get an idea as to what a system is like when systemd isn’t around), so I guess I’d be installing artix instead if I reinstalled?

It looks like you got caught in the recent shift in OpenRC from using sysvinit to their own init. Even if I cound find the older packages, I’m not sure they would work, as I’m not sure how much actually got changed in your system in the failed shift.

It probably is best to just save your hidden “dotfiles” from your home directory and reinstall. I don’t think Artix has an XFCE version, though. You could reinstall with the last Manjaro OpenRC iso. But then you’d also have to migrate. Sorry there’s no easy options here…

1 Like

Or you could transition to artix via reinstall.

  1. Save everything in $HOME, including especially the dotfiles.

  2. save your packages with

    pacman -Qqet > Packages-to-install.txt
    
  3. install barebones artix with their installer

  4. copy your old $HOME to your new $HOME

  5. install your package with

    sudo pacman -Sy $(cat /path/to/Packages-to-install.txt)
    
  6. enable the right services and your display manager.

  7. profit. You now have artix with the same packages and settings as your old installation

Troubleshooting step 5: artix does not have all the same packages as manjaro, and some packages have different names. Filter out those packages from your package list. Easy way to do this is (when booted to artix)

  pacman -Sqq > available-packages.txt
  sudo pacman -Sy $(grep -vf /path/to/available-packages.txt /path/to/Packages-to-install.txt)
1 Like

Thanks for the help, everyone! I’ve now resolved the issue by performing a migration to Artix Linux via the chroot. Here’s a rough guide on what I did for any other unlucky people out there who stumble upon this post:

  1. Boot using manjaro-architect
  2. Use lsblk to find the root & boot partitions
  3. Mount the root partition: mkdir /mnt/os; mount /dev/sdXY /mnt/os
  4. Mount /boot/efi: mount /dev/sdZW /mnt/os/boot/efi
  5. Enter the chroot: manjaro-chroot /mnt/os
  6. Follow the Artix Linux migration guide here: https://artix-linux.github.io/migrate/
  7. Update /etc/conf.d/keymaps to set appropriate keymap & re-enable windows key
  8. Reboot!
  9. Re-set hostname
  10. Wonder why no X-based programs work
  11. Reboot again
  12. Find that everything is fine :smiley_cat:

I did try downgrading openrc to 0.26.3 with a package file from a (wiser!) friend’s pacman cache and removing openrc-sysvinit, but it didn’t appear to help :frowning:

It looks like everything is working (mostly) as intended now (minus a few minor issues here and there that are easy to fix)

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by