Failed to commit transaction in Upgrading

I am upgrading to the latest version via GUI, but at the end of the process I received the following error:

conflicting files:

  • konsole: /etc/xdg/konsolerc already exists in filesystem (owned by minisforum-kde-settings)

what can i do?

I’m guessing you overwrote that file when you installed minisforum-kde-settings … as manjaro-kde-settings provides that file as well and you would have encountered the same error at that time.

So … choose one (removing the other package) or overwrite the file (you can also delete it first … accomplishing the same thing).

… or … its a known issue?

I’m getting the same error when trying to upgrade at the moment. I do not have the minisforum-kde-settings package installed.

Removing the file in question /etc/xdg/konsolerc (after a backup), allowed to do the update

This conflict is happening on all of my Manjaro machines as well

@lorenzosu @saltymedic
The repos should already have the fix in them.
Sort your mirrors and refresh/update.
If that somehow still doesnt work … you can remove the file first by hand
(its going to be replaced with the updated file anyways … but we can back it up by moving)

sudo mv /etc/xdg/konsolerc /etc/xdg/konsolerc.bak

Maybe you want to clear your cache as well. For example to remove everything;

paccache -rvk0

And of course go ahead with the update (will include a mirrors sort)

sudo pacman-mirrors -f && sudo pacman -Syyu

All good by my side, thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.