Failed to build XnConvert

Installed and was using XnConvert, but there were two entries for it in context menus. I uninstalled it and attempted to reinstall. Have retried many times, including downloading tar file manually. No luck yet.

Preparing...
Cloning xnconvert build files...
Checking xnconvert dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building xnconvert...
==> Making package: xnconvert 1.83-2 (Wed 12 Feb 2020 04:08:18 PM CST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found xnconvert.desktop
-> Found XnConvert-linux-x64_1.83.tgz
==> Validating source files with sha256sums...
xnconvert.desktop ... Passed
==> Validating source_x86_64 files with sha256sums...
XnConvert-linux-x64_1.83.tgz ... FAILED
==> ERROR: One or more files did not pass the validity check!
Failed to build xnconvert

Would appreciate any suggestions here. Thanks.

the previous one you had installed may still be in your cache in /var/cache/pacman/pkg/

Edit PKGBUILD:

sha256sums_x86_64=('0e75d76e37a1654dc749a2dc16a4a1282ae36bd4085e834f0275c3f510a20a37')

Find the line that starts sha256sums_x86_64 replace with the one above.

It was. I removed it but build still failed.

Did this, but build still fails.

that makes things more difficult. if you have it in your cache, it's already built and you could have just installed it. there was no need to rebuild it.

Ah, well i'm using pamac-manager. Didn't see that option. I'm very new to Manjaro/Arch, and my don't know much about Linux in general. Thanks for your suggestion. I'd still like to install this if posssible...

I use the xn suite from Flatpak : https://flathub.org/apps/search/xnview

This worked for me! Thanks so much for your help.

Forum kindly sponsored by