Failed to build/install brother-dcp165c

That package in AUR installs without problems on all arch-based Distros … except the new Manjaro Plasma.

No, you failed to install it on Manjaro. :wink:

No, I did not fail.
I installed brother-dcp165c on all arch-based distros I ever tested.
EndeavourOS, RebornOS, Archcraft, Arco, Garuda and on Manjaro.
Many times.
It worked because brother-dcp165c is in the AUR. There is only one.
Same applies for brscan3.

But in the latest Manjaro, it failed to install it. Not me, it was pacman who produced the error-messages, not me, not my fault.

pacman is not used for the AUR.

Unless you manually git cloned the source from AUR, ran makepkg on it, then used pacman -U on the resulting package. Is that what you did?

You also said previously that it didnt produce any errors … so I am double or triple confused.

You make it sound like you are familiar with these things so does that mean you do not need help?

If you do … then maybe provide some info like these aforementioned errors … and whether or not you have followed the basic instructions on the use of the AUR.

Oh, so you’ve been able to install it then? :wink:

Out of curiosity I tried to install both (I also use KDE/Plasma), and they both successfully installed (I use yay for AUR). What sort of errors did you get?

It works fine here:

Extracting sources...
  -> Extracting dcp165clpr-1.1.2-2.i386.rpm with bsdtar
  -> Extracting dcp165ccupswrapper-1.1.2-2.i386.rpm with bsdtar
==> Starting build()...
patching file ./usr/local/Brother/Printer/dcp165c/inf/setupPrintcapij
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "brother-dcp165c"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Adding install file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: brother-dcp165c 1.1.2-1 (Tue 25 Apr 2023 07:22:24 PM EDT)
==> Cleaning up...

Most likely you forgot to install base-devel first:
sudo pacman -Syu base-devel --needed
and after that you can build AUR packages with pamac build

…and perhaps base-devel should be included as a package in new isos, so as not to keep answering the same questions, fixing the same errors.

Which ones?

I agree with @banjo

My question to @bogdancovaciu :

How come that a user ( who is not an expert for linux, for arch, for IT ) should install base-devel ?
This is completely new to me.

I am using Manjaro at least 1 year and never ever , in no version of Manjaro, I had to install base-devel in order to install brother-dcp165c from the AUR.

Same applies to all other Arch-based distros.
They all deliver their distro with base-devel already installed as default.

So would you mind telling me why Manjaro changed this in the latest version ?
Makes no sense in my view.

The error-message without base-devel:

==> FEHLER: Ein Fehler geschah in build().
    Breche ab...
 -> Fehler beim Erstellen: brother-dcp165c-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
brother-dcp165c - exit status 4

After installation of base-devel ( I used yay for it ), the brother-drivers were installed without problems as it should be.

Manjaro didn’t change this. Either you installed it without your knowledge before or the AUR scripts didnt require these packages (and now they do).

No, I never installed base-devel myself.
It is the fault of Manjaro. I downloaded the latest version. That is all.

Edit: I don’t read every comment or announcement on a distro-forum.
Makes no sense.

I just see a distro (someone pointing to it on a youtube-channel (there are many channels about linux out there), download the iso and install it.
In about 99 percent this results in no problems at all when I have to install the brother-drivers from the AUR.

I will not use Manjaro , I am happy with EndeavourOS and RebornOS and LinuxMint-21.1-Xfce at this time.

Just delete the whole thread. I did not start it, you did.

I always installed base-devel for years, it is not new.

This is caused by spliiting the package in arch, also not new. Following arch news or manjaro anouncements is helpful.

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention

keep in mind to read the announcements of the latest update that @philm always leaves here in the forum. the issue and how to “solve” it is already and completely described in this thread. and manjaro is arch-based and if there’s someone to “blame” then it is arch.

otherwise it is always a good point to start if a new update is released if there are announcements at arch

if you had checked it you will see

I know that AUR is often one of the main reasons to switch to a Arch-based distribution, but AFAIK AUR is still not officially supported by Manjaro, and is still not enabled by default in pamac. So i’d say base-devel not being installed by default either is coherent.

You can’t decently use an Arch-based distribution if you don’t want to learn how it works underneath the surface. Manjaro provides many tools to ease its management, but it can’t cover everything.
Furthermore, considering AUR is not officially supported, you must learn how AUR packages are managed.

1 Like