"Failed saving grub configuration!"

I’m trying to use Grub Customizer to update my List Configuration and Appearance settings.
However, I’m getting an error that’s basically unknown.
Here’s the error:
failed running 'grub-mkconfig -o “/boot/grub/grub.cfg” output:
. a bunch of stuff about successfully loading resources here .
/usr/bin/grub-probe: warning: unknown device type nvem0n1
error: syntax error
error: incorrect command
ensure there are no errors in /etc/default/grub

I then go to /etc/default/grub and this is the config:
GRUB_DEFAULT=“saved”
GRUB_TIMEOUT=“10”
GRUB_TIMEOUT_STYLE=“hidden”
GRUB_DISTRIBUTOR=“Manjaro”
GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor udev.log_priority=3”
GRUB_CMDLINE_LINUX=""

    # If you want to enable the save default function, uncomment the following
    # line, and set GRUB_DEFAULT to saved.
    GRUB_SAVEDEFAULT="true"

    # Preload both GPT and MBR modules so that they are not missed
    GRUB_PRELOAD_MODULES="part_gpt part_msdos"

    # Uncomment to enable booting from LUKS encrypted devices
    #GRUB_ENABLE_CRYPTODISK="y"

    # Uncomment to use basic console
    GRUB_TERMINAL_INPUT="console"

    # Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT="console"

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command 'videoinfo'
    GRUB_GFXMODE="auto"

    # Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX="keep"

    # Uncomment if you want GRUB to pass to the Linux kernel the old parameter
    # format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
    #GRUB_DISABLE_LINUX_UUID="true"

    # Uncomment to disable generation of recovery mode menu entries
    GRUB_DISABLE_RECOVERY="true"

    # Uncomment and set to the desired menu colors.  Used by normal and wallpaper
    # modes only.  Entries specified as foreground/background.
    GRUB_COLOR_NORMAL="light-gray/black"
    GRUB_COLOR_HIGHLIGHT="green/black"

    # Uncomment one of them for the gfx desired, a image background or a gfxtheme
    #GRUB_BACKGROUND="/usr/share/grub/background.png"
    GRUB_THEME="/boot/grub/themes/starfield/theme.txt"

    # Uncomment to get a beep at GRUB start
    #GRUB_INIT_TUNE="480 440 1"

Welcome at the forum, @whomadewho86

Simply don’t use Grub Customizer on Manjaro’s grub which is highly modified from grub vanilla and therefore using Grub Customizer could cause serious issues.

Usually, /etc/default/grub is the file to be edited in a normal editor like nano to apply changes.

2 Likes

Moved to #support:Installation

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.