Failed retrieving file Timed out 10000 milisecond

I am a very new user to manjaro and pacman and I have an issue which I can’t find solution here. It has to do with synchronizing package database.

I used Q4OS with trinity desktop and Zorin OC lite in the past with a very old computer, but i heard that manjaro is a better overall and so far i agree
I was using “apt-get” or “apt install” to update or install stuff
But now everytime i use “pacman -Sy” to update it throws that error

The error is always the same : error: failed retrieving file ‘core.db’ from : Resolving timed out after 10000 milliseconds
That error but multiple times(for different mirrors I assume and for multiple packages

I tried to custom the mirror based on the active ones , I tried to select mirror from countries close to my country (Greece)
Please help me

Welcome to the forum! :slight_smile:

Please, pretty please, Don’t Do That™! :man_facepalming:

Try this… :arrow_down:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu 

Let it finish ─ do not switch off the computer or hit the reset button. And then tend to any .pacnew files you may have ─ merge them with your customized versions, if applicable.

Yeah I learned it wasnt working after 1 minute of search :sweat_smile:

I can’t find any .pacnew files

That’s okay ─ there aren’t always. But it’s just in case there are. :wink:

It did fail to synchronize all databases

Try… :arrow_down:

sudo rm -f /var/lib/pacman/db.lck

… and then run… :arrow_down:

sudo pacman -Syyu

isn’t that the solution for the unable to lock database?
(Of course I will try it)

still failed all packages

I’m from Greece too, the mirrors seem to be significantly slower and less functional than the normal mirrors. Switch back to those and your problem will be solved.