[FAILED] failed to start pkgfile database update

You disable it’s timer unit, that in this case triggers it’s own service in time.

sudo systemctl disable pkgfile-update.timer

sudo systemctl mask pkgfile-update.timer

sudo systemctl mask pkgfile-update.service
(I prefer using “SystemdGenie”)

i got the error again today at boot,and what’s weird is that it’s with a week’s difference.

sudo systemctl status pkgfile-update.service

shows all the errors are related to “http ://linorg.usp.br/manjaro/”
i don’t remember what it was last week.


Description=pkgfile database update timer


1 Like


I also have this problem at both my desktop and laptop. For me the dependency was created by ‘manjaro-zsh-config’. The error message shows up after each shutdown/restart and delays the process by ~15 seconds.

❯ systemctl status pkgfile-update.service

● pkgfile-update.service - pkgfile database update
     Loaded: loaded (/usr/lib/systemd/system/pkgfile-update.service; static)
     Active: failed (Result: exit-code) since Wed 2021-04-07 11:23:23 EEST; 5min ago
TriggeredBy: ● pkgfile-update.timer
    Process: 2610 ExecStart=/usr/bin/pkgfile -u (code=exited, status=1/FAILURE)
   Main PID: 2610 (code=exited, status=1/FAILURE)

Apr 07 11:23:23 kubi-manjaro systemd[1]: Starting pkgfile database update...
Apr 07 11:23:23 kubi-manjaro pkgfile[2610]: warning: download failed: https://mirrors.fossho.st/manjaro/stable/core>
Apr 07 11:23:23 kubi-manjaro pkgfile[2610]: warning: download failed: https://mirrors.fossho.st/manjaro/stable/extr>
Apr 07 11:23:23 kubi-manjaro pkgfile[2610]: warning: download failed: https://mirrors.fossho.st/manjaro/stable/comm>
Apr 07 11:23:23 kubi-manjaro pkgfile[2610]: warning: download failed: https://mirrors.fossho.st/manjaro/stable/mult>
Apr 07 11:23:23 kubi-manjaro systemd[1]: pkgfile-update.service: Main process exited, code=exited, status=1/FAILURE
Apr 07 11:23:23 kubi-manjaro systemd[1]: pkgfile-update.service: Failed with result 'exit-code'.
Apr 07 11:23:23 kubi-manjaro systemd[1]: Failed to start pkgfile database update.

Try running this command. I found this on forum regarding the same issue

systemctl start pkgfile-update.service

This command worked for me. This does not seem to be a permanent solution as the error would again appear after few days. I had to run the command again to get rid of the error for few more days :expressionless:.

After running the above command, run this to see if the error went away

systemctl --failed

I was having the same problem of KubiGR, and I have solved this way, Thank you :pray:

My problem was that I installed fzf (fuzzy searcher) with zsh keybindings. I uninstalled zsh and fzf and then reinstalled fzf without the optional zsh keybindings. Problem has subsequently been solved. Hope this helps anyone who comes looking here. :slight_smile:

does removing thos files affect my system anyway?? this message at startup is annoying :sweat_smile:

It seems that pkgfile can be uninstalled independently. What about current solutions? If I uninstall manjaro-zsh-config, pkgfile would not be uninstalled and the annoying [FAILED] message still shoots into my eye.

Will simply remove both manjaro-zsh-config as well as pkgfile work?
BTW, instead of oh-my-zsh, you may try starship at https://starship.rs :wink: I switched to the latter months ago and got rid of the problem.

No, I switched to bash (laugh)

Its just because pkgfile is being installed by default. Maybe manjaro could add a choose bash/zsh/fish/other shell option in calamares?

1 Like

I still have this issue. The manual update via systemctl start pkgfile-update.service makes the error disappear for a few days but that’s it. Should I uninstall zsh and friends this way and reinstall it some other way?

I think that manjaro architect has a choice for a shell option, that’s how I installed zsh in the first place.

Now KDE and GNOME all use zsh as default, you can only uninstall pkgfile.

Or you can uninstall all things related by zsh and reinstall zsh only, then use bash -c "$(curl -fsSL https://raw.githubusercontent.com/ohmyzsh/ohmyzsh/master/tools/install.sh)" to install oh-my-zsh

1 Like

You can disable pkgfile services.

sudo systemctl stop pkgfile-update.service
sudo systemctl disable pkgfile-update.service
sudo systemctl stop pkgfile-update.timer
sudo systemctl disable pkgfile-update.timer
1 Like

really? Arch and Deabian with KDE Plasma still use bash as defult(At Auguest I use them).

You can install a Manjaro KDE just now. In LiveCD it uses bash but after installation it uses zsh.

Also, zsh is installed by default so if Manjaro use bash as default pkgfile will still run.

This works for me. pkgfile as a depend of manjaro-zsh-condif and octopi(two insalled by default). Diable it will cause any loss?? Hope nothing