[FAILED] Failed to start light Display Manager

Hello,

So I’ve been running Manjaro for a little under a year but when I booted up my computer this evening I got this error:
[FAILED] Failed to start Light Display Manager

I do remember seeing a big update install the previous day, like 133 at once, so I’m guessing that caused the issue. I don’t have access to my desktop so I can’t really copy and paste things into a forum post, but I can try to type it out if you need some info. This isn’t an essential computer, just what I use daily at home, I still have my work laptop, but I would love to fix this.

Using mhwd -li I know I have installed currently:
video-linux 2018.05.04
video-nvidia-440xx 2020.10.04

From tty, I have tried:

“pacman -Syyu” and reboot
“downgrade lightdm” (with version 1:1.30.0-4 and 1:1.30.0-3) and reboot
“pacman -S linux58-nvidia-440xx” and reboot

  1. run mhwd -i pci video-linux
  2. run mhwd -r pci video-nvidia-450x
  3. reboot

The command “systemctl status lightdm” gives me:

lightdm.service - Light Display Manager
Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2020-11-19 19:30:11 CST 1min 15s ago
Docs: man:lightdm(1)
Process: 1451 ExecStart=/usr.bin/lightdm (code=exited, status=1/Failure)
Main PID: 1451 (code=exited, status=1/Failure)

Nov 19 19:30:11 systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Nov 19 19:30:11 systemd[1]: Stopped Light Display Manager.
Nov 19 19:30:11 systemd[1]: lightdm.service: Start request repeated too quickly.
Nov 19 19:30:11 systemd[1]: lightdm.service: Failed with result ‘exit-code’.
Nov 19 19:30:11 systemd[1]: Failed to start Light Display Manager.

Thanks for your help,

Can you boot to your desktop after uninstalling the drivers?

I can remove the video-linux driver, and upon reboot nothing changes, when I try to remove the nvidia driver I get an error:

error: failed to prepare transaction (could not satisfy dependencies)
: : removing linux58-nvidia-440x breaks dependency ‘linux58-nvidia-440xx’ required by linux-latest-nvidia-440xx
: : removing linux58-nvidia-440x breaks dependency ‘linux58-nvidia-440xx’ required by linux-lts-nvidia-440xx
Error: pacman failed!
Error: script failed!

Well just an update . . . I ran a a restore of a snapshot I had from timeshift from last week from the command line. I know have a new problem:

error: symbol ‘grub_calloc’ not found
entering rescue mode

I’ll work on this more tomorrow I guess, if you have any ideas I would appreciate it. Sounds like I might need to create a live usb, which I could probably do.

Okay, so I fixed the issue although I still don’t know exactly what the issue was.

Using “Ctrl + Alt + F2” I went into the tty2 terminal, logged in as root, and I restored a timeshift snapshot from before the system updates with command:

timeshift --restore

Then I made sure to decline the grub reinstall so Grub didn’t get messed up.
Now everything is normal, I just can’t install updates without risking breaking light manager again.

All hail timeshift our lord and savior! May his shiftiness forever reign!

Sorry to hijack this. Ran inter the very same problem and this has actually helped me getting back into a graphical system.

Is there kind of a bug tracker for Manjaro where we could write a ticket (or find an existing) to follow on this?

Probably no…

I have exactly the same problem. I solved it with timeshift but i can’t make updates.

Hello Everyone,

I had the same issue described in the opening post since the update from around the 20th of November. Which had forced me to restore a previous snapshot from my timeshift backlog as well. Today, however, I managed to fix the problem for my system. My hope is that even though I’m a newbie to Linux in general, my solution can be of help to others.

First off two things you should know: When I had the Light Display Manager startup problem after updates, I was running Kernel 5.8 as well as the proprietary Nvidia drivers from the 440xx line.

So here is what I did:

  1. Using the command “mhwd-kernel --install linux59” as a super user I installed the 5.9 kernel. (I got a message that I should first update my system, which I ignored. Starting up my system with that new kernel thus resulted in the same Light Display Manager startup failure that I had experienced when updating my system regularly).

  2. With the new 5.9 kernel installed, I then installed the linux59-nvidia-450xx package. Removing and replacing all conflicting packages in the process (This also forced me to install all pending updates that had accumulated since the problem came up last week).

  3. Reboot

And that was it. I have no issues booting into my up-to date system and getting to my desktop environment with this new kernel. My old kernel is another matter entirely (see below).

I hope this may be of use to others. Good luck with your systems.

P.S.
A question for those more knowledgeable than I (I’m aware that this is the probably the wrong place for it but I also wanted to inform/warn those who are interested in my solution of the problems it might cause): When I try to boot with the 5.8 kernel now, the process results in a major error. Both my efi and home directory fail to mount and I get thrown into an emergency diagnostics mode. Can someone elucidate a guess as to why that happens?