Failed Boot Manjaro Linux from USB drive

I am trying to do a dual boot on my Asus rog flow x13 with windows 10.
I created my bootable usb drive version manjaro-gnome-22.0.5-230316-linux61.
When I go to the bios, i have to option UEFI and UEFI2 i choose the first one, i choose to boot with open source driver but then it goes on a black screen and it boot back to windows, i dont know what to do. I had manjaro installed in dual boot before and i did the same process to intsall it again, so i dont know what to do

How did you create the bootable USB? Maybe the following tutorial will be helpful:

I downloaded the .iso file on manjaro website and created bootable usb drive with Rufus.
Now I tried putting my usb drive in first in the boot menu when i boot manjaro i have black screen and it boot back to manjaro with the menu

I think i found my mistake I mixed UEFI with MBR partition scheme.
i will do my usb drive again and try

1 Like

It’s also likely that “secure boot” or some such option is enabled - but Manjaro cannot do that (not without additional steps that are not doable from within the installer).

So: make sure that is not enabled, else Manjaro installation will fail

i checked, secure boot is disabled, do i have to disable legacy boot too ?

Likely not, no.
Your Windows in likely installed in uefi mode - so to avoid problems, install Manjaro in the same mode.

But no need to disable legacy boot to achieve that.

I created my bootable drive again i still have the same problem, i boot to manjaro i choose open source and then it reboot my pc

We have no hardware info from you as far as I’m aware.
so: no idea what the relevance of booting with the “open source drivers” option really is.
Usually, it relates to NVIDIA graphics …

It should boot either way - no idea why it - like you say
it just reboots your system.

Could be a number of issues - one of them being:
are you sure your created boot medium actually is valid and does work?

perhaps use Ventoy to create the bootable drive - it’s a rather new, but versatile and reliable option

I created a bootable usb drive with an older version of manjaro and everything worked fine.

So, I don’t know if there is the problem with current version of manjaro gnome ?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.