Extra character in zsh shell

I am using Manjaro Gnome right now with zsh shell. I am trying to compile a cpp program and after the output, it shows me an extra ASCII character. Here is a screenshot. How can I fix this? Screenshot from 2020-12-09 12-48-30


That means you forgot to output a newline \n at the end of the string that is output in the ./o program…

It worked, But it works fine with bash, no need to put any extra new line \n. Only happens with zsh

That might be related to the prompt setting of bash.
Because Zsh allows to modify the prompt in many different ways, it does not start with a newline IIRC.
For nice stuff with Zsh see: [Poll] Zsh with Oh-My-Zsh as default

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.