External USB drive does not mount after update

The problem:
my external USB drive (LaCie, Ltd Minimus USB 3 2TB) used to automount when switched on.
After yesterday’s system update I need to mount it manually through CLI.
Other USB flash-disks mount normally upon connection.
Noprmally it would mount in a directory in /run/media/oren
However, it does appear to be healthy.
This is the ouput of lsusb (unmounted):
Bus 002 Device 002: ID 059f:1042 LaCie, Ltd Minimus USB 3

This is the output of fdisk -l:

Disk /dev/sdb: 1.82 TiB, 2000398934016 bytes, 3907029168 sectors
Disk model: 001-9VT156      
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x48ff8957

Device     Boot Start        End    Sectors  Size Id Type
/dev/sdb1        2048 3907026943 3907024896  1.8T  7 HPFS/NTFS/exFAT

and this is the output of lsblk:

sdb           8:16   0   1.8T  0 disk 
└─sdb1        8:17   0   1.8T  0 part

This is my system information:

**OS**: Manjaro Linux x86_64
**Kernel**: 6.1.55-1-MANJARO
**Shell**: fish 3.6.1
**DE**: Plasma 5.27.8
**Theme**: Aritim-Dark_DEV [Plasma], Adwaita [GTK2/3]
**CPU**: Intel i5-8400 (6) @ 4.000GHz
**GPU**: Intel CoffeeLake-S GT2 [UHD Graphics 630]
**Memory**: 2751MiB / 7833MiB
**Disk (/)**: 65G / 127G (54%)
**Disk (/mnt/sda1)**: 53G / 537G (10%)

Any assistance will be much appreciated.


1 Like

It is probably an NTFS file system. Newer kernels switched to ntfs3 as default; previously ntfs-3g. It seems that ntfs3 is more strictly about errors. Check your file systems on Windows, since Linux doesn’t have any check/repair tools like on Windows.

I had same issue. Running check for errors on windows seems to have solved issue even though no errors were reported. Is there a way to switch back to using ntfs-3g maybe?

sudo bash -c 'echo "blacklist ntfs3" > /etc/modprobe.d/disable-ntfs3.conf'

Reboot then.


Most common cause for these type of issues is the dirty bit set by Windoof when not properly shutdown (only hibernating). Can be often fixed within Win by using file system checking tools.

1 Like

Thank you very much @megavolt and all who chimed in.
Rolling back to ntfs-3g worked perfectly.

Thank you very much @bunnycore

Thank you very much @Wollie

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.